]> git.pld-linux.org Git - packages/perl-DBD-ODBC.git/blob - perl-DBD-ODBC.spec
- removed zero-sized .bs file
[packages/perl-DBD-ODBC.git] / perl-DBD-ODBC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBD
7 %define         pnam    ODBC
8 Summary:        DBD::ODBC - ODBC Driver for DBI
9 Summary(pl.UTF-8):      DBD::ODBC - sterownik DBI do ODBC
10 Name:           perl-DBD-ODBC
11 Version:        1.43
12 Release:        2
13 # GPL or Artistic as specified in perl README file
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  35e37488170b5111f826226c4d466961
18 URL:            http://search.cpan.org/dist/DBD-ODBC/
19 BuildRequires:  perl-DBI >= 1.21
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  unixODBC-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 DBD::ODBC is DBD module interfacing the ODBC databases.
26
27 %description -l pl.UTF-8
28 DBD::ODBC jest modułem DBD komunikującym się z bazami danych z użyciem
29 ODBC.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %{__perl} -pi -e 's/.*(@\$\(NOOP\))/\t$1/' Makefile.PL
35 %{__perl} -pi -e 's@/lib/libodbc@/%{_lib}/libodbc@' Makefile.PL
36
37 %build
38 %{__perl} Makefile.PL \
39         -o /usr \
40         INSTALLDIRS=vendor
41
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %{?with_tests:%{__make} test}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/DBD/ODBC.pm
61 %{perl_vendorarch}/DBD/ODBC
62 %dir %{perl_vendorarch}/auto/DBD/ODBC
63 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/ODBC/ODBC.so
64 %{_mandir}/man3/*
This page took 0.10894 seconds and 4 git commands to generate.