]> git.pld-linux.org Git - packages/perl-DBD-ODBC.git/blob - perl-DBD-ODBC.spec
- rebuild with perl 5.26
[packages/perl-DBD-ODBC.git] / perl-DBD-ODBC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBD
7 %define         pnam    ODBC
8 Summary:        DBD::ODBC - ODBC Driver for DBI
9 Summary(pl.UTF-8):      DBD::ODBC - sterownik DBI do ODBC
10 Name:           perl-DBD-ODBC
11 Version:        1.52
12 Release:        3
13 # GPL or Artistic as specified in perl README file
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5f4eadbbb7f1ac6e77ab92276ccae573
18 URL:            http://search.cpan.org/dist/DBD-ODBC/
19 BuildRequires:  perl-DBI >= 1.21
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  unixODBC-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 DBD::ODBC is DBD module interfacing the ODBC databases.
26
27 %description -l pl.UTF-8
28 DBD::ODBC jest modułem DBD komunikującym się z bazami danych z użyciem
29 ODBC.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 # pass PERL_MM_USE_DEFAULT to avoid threads warning prompt
36 PERL_MM_USE_DEFAULT=1 \
37 %{__perl} Makefile.PL \
38         -o /usr \
39         INSTALLDIRS=vendor
40
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %{?with_tests:%{__make} test}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/DBD/ODBC.pm
60 %{perl_vendorarch}/DBD/ODBC
61 %dir %{perl_vendorarch}/auto/DBD/ODBC
62 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/ODBC/ODBC.so
63 %{_mandir}/man3/DBD::ODBC.3pm*
This page took 0.118046 seconds and 4 git commands to generate.