]> git.pld-linux.org Git - packages/perl-DBD-ODBC.git/blob - perl-DBD-ODBC.spec
rebuild with perl 5.32
[packages/perl-DBD-ODBC.git] / perl-DBD-ODBC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    DBD
6 %define         pnam    ODBC
7 Summary:        DBD::ODBC - ODBC Driver for DBI
8 Summary(pl.UTF-8):      DBD::ODBC - sterownik DBI do ODBC
9 Name:           perl-DBD-ODBC
10 Version:        1.60
11 Release:        4
12 # GPL or Artistic as specified in perl README file
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e9a2bec96744f960832e4f47f9e4bcd0
17 URL:            http://search.cpan.org/dist/DBD-ODBC/
18 BuildRequires:  perl-DBI >= 1.21
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  unixODBC-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         __noautoreqfiles        Changes.pm FAQ.pm TO_DO.pm
24
25 %description
26 DBD::ODBC is DBD module interfacing the ODBC databases.
27
28 %description -l pl.UTF-8
29 DBD::ODBC jest modułem DBD komunikującym się z bazami danych z użyciem
30 ODBC.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 # pass PERL_MM_USE_DEFAULT to avoid threads warning prompt
37 PERL_MM_USE_DEFAULT=1 \
38 %{__perl} Makefile.PL \
39         -o /usr \
40         INSTALLDIRS=vendor
41
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %{?with_tests:%{__make} test}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/DBD/ODBC.pm
61 %{perl_vendorarch}/DBD/ODBC
62 %dir %{perl_vendorarch}/auto/DBD/ODBC
63 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/ODBC/ODBC.so
64 %{_mandir}/man3/DBD::ODBC.3pm*
This page took 0.36836 seconds and 4 git commands to generate.