]> git.pld-linux.org Git - SPECS.git/blob - perl-Crypt-X509.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Crypt-X509.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    X509
7 Summary:        Crypt::X509 - Parse a X.509 certificate
8 Name:           perl-Crypt-X509
9 Version:        0.52
10 Release:        1
11 License:        Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  dfca86dbbfa9d1e470a18f2b0d140dc0
15 URL:            http://search.cpan.org/dist/Crypt-X509/
16 BuildRequires:  perl-Convert-ASN1
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Crypt::X509 parses X.509 certificates. Methods are provided for
24 accessing most certificate elements.
25
26 %prep
27 %setup -q -n %{pdir}-%{pnam}-%{version}
28
29 %build
30 %{__perl} Makefile.PL \
31         INSTALLDIRS=vendor
32
33 %{__make} \
34         CC="%{__cc}" \
35         OPTIMIZE="%{rpmcflags}"
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes README
51 %{perl_vendorlib}/Crypt/X509.pm
52 %{_mandir}/man3/Crypt::*.3pm*
This page took 0.142157 seconds and 3 git commands to generate.