]> git.pld-linux.org Git - packages/perl-Crypt-Twofish.git/blob - perl-Crypt-Twofish.spec
9b1553ca16146f90557022d201cf89083a5064be
[packages/perl-Crypt-Twofish.git] / perl-Crypt-Twofish.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Twofish
8 Summary:        Crypt::Twofish Perl module - the Twofish encryption algorithm
9 Summary(pl.UTF-8):      Moduł Perla Crypt::Twofish - algorytm szyfrowania Twofish
10 Name:           perl-Crypt-Twofish
11 Version:        2.12
12 Release:        4
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  39937a00e4d5e6a5d700d1cd9991517c
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module implements Twofish encryption. It supports the Crypt::CBC
23 interface. Twofish is a 128-bit symmetric block cipher with a variable
24 length (128, 192, or 256-bit) key, developed by Counterpane Labs. It
25 is unpatented and free for all uses, as described at
26 <http://www.counterpane.com/twofish.html>.
27
28 %description -l pl.UTF-8
29 Ten moduł jest implementacją szyfrowania Twofish. Obsługuje interfejs
30 Crypt::CBC. Twofish jest 128-bitowym symetrycznym szyfrem blokowym ze
31 zmienną długością klucza (128, 192 lub 256 bitów), opracowanym przez
32 Counterpane Labs. Nie jest opatentowany i można go swobodnie używać
33 do dowolnych celów, zgodnie z opisem pod adresem
34 <http://www.counterpane.com/twofish.html>.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Crypt/Twofish.pm
61 %dir %{perl_vendorarch}/auto/Crypt/Twofish
62 %{perl_vendorarch}/auto/Crypt/Twofish/*.bs
63 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish/*.so
64 %{_mandir}/man3/*
This page took 0.045304 seconds and 2 git commands to generate.