]> git.pld-linux.org Git - packages/perl-Crypt-TripleDES.git/blob - perl-Crypt-TripleDES.spec
- cosmetic unification: s/^%define\s+(pdir|pnam)\s+/%define\t$1\t/
[packages/perl-Crypt-TripleDES.git] / perl-Crypt-TripleDES.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Crypt
7 %define pnam    TripleDES
8 Summary:        Crypt::TripleDES Perl module - pure Perl Triple DES implementation
9 Summary(pl):    Modu³ Perla Crypt::TripleDES - czysto perlowa implementacja Triple DES
10 Name:           perl-Crypt-TripleDES
11 Version:        0.24
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  90b562175a8f6c5f6bc3eacaddffbcde
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module implements 3DES encryption in ECB mode. The code is based
25 on Eric Young's implementation of DES in pure perl. It's quite slow
26 because of the way Perl handles bit operations and is not recommended
27 for use with large texts.
28
29 %description -l pl
30 Ten modu³ jest implementacj± szyfrowania 3DES w trybie ECB. Kod bazuje
31 na czysto perlowej implementacji DES Erica Younga. Jest dosyæ wolny ze
32 wzglêdu na sposób obs³ugi operacji bitowych przez interpreter i nie
33 jest zalecany do u¿ycia z du¿ymi tekstami.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{perl_vendorlib}/Crypt/*.pm
60 %{_mandir}/man3/*
61 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.080569 seconds and 4 git commands to generate.