]> git.pld-linux.org Git - SPECS.git/blob - perl-Crypt-SMIME.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Crypt-SMIME.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    SMIME
7 Summary:        Crypt::SMIME - S/MIME message signing, verification, encryption and decryption
8 Summary(pl.UTF-8):      Crypt::SMIME - podpisywanie, weryfikacja, szyfrowanie i odszyfrowywanie wiadomości S/MIME
9 Name:           perl-Crypt-SMIME
10 Version:        0.25
11 Release:        1
12 License:        LGPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  7afe3f4dedd6f569efb1effcd432eacc
16 URL:            http://search.cpan.org/dist/Crypt-SMIME/
17 BuildRequires:  openssl-devel >= 0.9.9
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl(ExtUtils::CChecker)
20 BuildRequires:  perl(ExtUtils::PkgConfig)
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  openssl
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides a class for handling S/MIME messages. It can
29 sign, verify, encrypt and decrypt messages. It requires libcrypto
30 (http://www.openssl.org).
31
32 %description -l pl.UTF-8
33 Ten moduł dostarcza klasę do obsługi wiadomości S/MIME. Potrafi
34 podpisywać, weryfikować podpisy, szyfrować i odszyfrowywać takie
35 wiadomości. Wymaga biblioteki libcrypto z pakietu OpenSSL.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/SMIME.3pm $RPM_BUILD_ROOT%{_mandir}/man3/Crypt::SMIME.3pm
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorarch}/Crypt/SMIME.pm
64 %dir %{perl_vendorarch}/auto/Crypt/SMIME
65 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/SMIME/SMIME.so
66 %{_mandir}/man3/Crypt::SMIME.3*
This page took 0.139908 seconds and 3 git commands to generate.