]> git.pld-linux.org Git - packages/perl-Crypt-Rijndael.git/blob - perl-Crypt-Rijndael.spec
- release 3
[packages/perl-Crypt-Rijndael.git] / perl-Crypt-Rijndael.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Rijndael
8 Summary:        Crypt::Rijndael Perl module - Rijndael encryption algorithm
9 Summary(pl.UTF-8):      Moduł Perla Crypt::Rijndael - algorytm szyfrowania Rijndael
10 Name:           perl-Crypt-Rijndael
11 Version:        1.07_02
12 Release:        3
13 # included COPYING contains LGPL v2, but README and module source says GPL
14 License:        GPL
15 Group:          Development/Languages/Perl
16 Source0:        http://search.cpan.org/CPAN/authors/id/B/BD/BDFOY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  61b2ebf10194b1f94f14d999cf68f5f9
18 Patch0:         %{name}-types.patch
19 URL:            http://search.cpan.org/dist/Crypt-Rijndael/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl(Test::Manifest) >= 1.14
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is Crypt::CBC compliant Rijndael cipher implementation.
29 Rijndael has just been selected as the Advanced Encryption Standard.
30
31 %description -l pl.UTF-8
32 Ten moduł jest zgodną z Crypt::CBC implementacją szyfru Rijndael.
33 Rijndael został niedawno wybrany jako standard zaawansowanego
34 szyfrowania (AES).
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %patch0 -p1
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes NEWS README
61 %{perl_vendorarch}/Crypt/*.pm
62 %dir %{perl_vendorarch}/auto/Crypt/Rijndael
63 %{perl_vendorarch}/auto/Crypt/Rijndael/*.bs
64 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Rijndael/*.so
65 %{_mandir}/man3/*
This page took 0.051012 seconds and 3 git commands to generate.