]> git.pld-linux.org Git - packages/perl-Crypt-RC4.git/blob - perl-Crypt-RC4.spec
- mass commit: cosmetics (removed trailing white spaces)
[packages/perl-Crypt-RC4.git] / perl-Crypt-RC4.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define         pdir    Crypt
3 %define         pnam    RC4
4 Summary:        Crypt::RC4 Perl module - RC4 encryption algorithm implementation
5 Summary(pl):    Modu³ Perla Crypt::RC4 - implementacja algorytmu szyfrowania RC4
6 Name:           perl-Crypt-RC4
7 Version:        2.02
8 Release:        2
9 License:        Artistic or GPL
10 Group:          Development/Languages/Perl
11 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 # Source0-md5:  4ca59a7e58ac9597c3b4f3f46ea22629
13 BuildRequires:  perl-devel >= 5.6
14 BuildRequires:  rpm-perlprov >= 4.1-13
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 A simple implementation of the RC4 algorithm. RC4 is a stream cipher
20 designed by Rivest for RSA Data Security (now RSA Security). It is a
21 variablekey-size stream cipher with byte-oriented operations. The
22 algorithm is based on the use of a random permutation.
23
24 %description -l pl
25 Prosta implementacja algorytmu RC4. RC4 jest szyfrem strumieniowym
26 opracowanym przez Rivesta dla RSA Data Security (teraz RSA Security).
27 Jest to szyfr strumieniowy o zmiennej d³ugo¶ci klucza z operacjami
28 zorientowanymi na bajty. Bazuje na u¿ywaniu losowych permutacji.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make}
37 %{__make} test
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes
51 %{perl_vendorlib}/Crypt/RC4.pm
52 %{_mandir}/man3/*
This page took 0.06439 seconds and 3 git commands to generate.