]> git.pld-linux.org Git - SPECS.git/blob - perl-Crypt-OpenSSL-RSA.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Crypt-OpenSSL-RSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-RSA
7 Summary:        Crypt::OpenSSL::RSA - RSA encoding and decoding, using the OpenSSL libraries
8 Summary(pl.UTF-8):      Crypt::OpenSSL::RSA - kodowanie i dekodowanie RSA przy użyciu OpenSSL
9 Name:           perl-Crypt-OpenSSL-RSA
10 Version:        0.31
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d33681e19d2094df7c26bc7a4509265e
17 URL:            https://metacpan.org/dist/Crypt-OpenSSL-RSA
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  perl-Crypt-OpenSSL-Guess >= 0.11
20 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.48
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 %if %{with tests}
25 BuildRequires:  perl-Crypt-OpenSSL-Random
26 BuildRequires:  perl-Test-Simple
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Crypt::OpenSSL::RSA provides the ability to RSA encrypt strings which
32 are somewhat shorter than the block size of a key.  It also allows for
33 decryption, signatures and signature verification.
34
35 %description -l pl.UTF-8
36 Moduł Crypt::OpenSSL::RSA udostępnia możliwość kodowania algorytmem
37 RSA łańcuchów, które są krótsze niż rozmiar bloku klucza. Pozwala
38 także na odszyfrowywanie oraz weryfikację podpisów.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make} \
47         CC="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorarch}/Crypt/OpenSSL/RSA.pm
65 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA
66 %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/*.al
67 %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/autosplit.ix
68 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/RSA.so
69 %{_mandir}/man3/Crypt::OpenSSL::RSA.3pm*
This page took 0.051095 seconds and 3 git commands to generate.