]> git.pld-linux.org Git - SPECS.git/blob - perl-Crypt-OTP.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Crypt-OTP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    OTP
7 Summary:        Crypt::OTP Perl module - OTP encryption method implementation
8 Summary(pl.UTF-8):      Moduł Perla Crypt::OTP - implementacja kodowania metodą OTP
9 Name:           perl-Crypt-OTP
10 Version:        2.00
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  af841dbb3641f73ee4048b15e6b56197
17 URL:            http://search.cpan.org/dist/Crypt-OTP/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The One Time Pad encryption method is very simple, and impossible to
25 crack without the actual pad file against which the to-be-encrypted
26 message is XOR'ed. Encryption and decryption are performed using
27 exactly the same method, and the message will decrypt correctly only
28 if the same pad is used in decryption as was use in encryption.
29
30 %description -l pl.UTF-8
31 Metoda kodowania OTP (One Time Pad - jednorazowa tablica) jest bardzo
32 prosta i niemożliwa do złamania bez znajomości właściwego pliku
33 tablicy, z którą wiadomość jest xorowana. Kodowanie i dekodowanie
34 odbywa się dokładnie tą samą metodą, a wiadomość może być odkodowana
35 poprawnie tylko przy użyciu tej samej tablicy, która była używana do
36 kodowania.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %{perl_vendorlib}/Crypt/OTP.pm
61 %{_mandir}/man3/*
This page took 0.669613 seconds and 3 git commands to generate.