]> git.pld-linux.org Git - packages/perl-Crypt-GPG.git/blob - perl-Crypt-GPG.spec
368cb9ed921a8a856fbcdc589c14c8f60e6c8c0e
[packages/perl-Crypt-GPG.git] / perl-Crypt-GPG.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    GPG
8 Summary:        Crypt::GPG Perl module - an Object Oriented interface to GnuPG
9 Summary(pl):    Modu³ Perla Crypt::GPG - obiektowo zorientowany interfejs do GnuPG
10 Name:           perl-Crypt-GPG
11 Version:        1.42
12 Release:        1
13 License:        Artistic or GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 BuildRequires:  perl-Expect >= 1.15
18 BuildRequires:  perl-Time-HiRes
19 BuildRequires:  perl-TimeDate
20 BuildRequires:  rpm-perlprov >= 3.0.3-16
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Crypt::GPG module provides near complete access to GnuPG
26 functionality through an object oriented interface. It provides
27 methods for encryption, decryption, signing, signature verification,
28 key generation, key export and import, and most other key management
29 functions. This module works almost identically to its cousin,
30 Crypt::PGP5. The two modules together provide a uniform interface to
31 deal with both PGP and GnuPG. Eventually, these modules will be folded
32 into a single module which will interface with GnuPG as well as all
33 versions of PGP.
34                                     
35 %description -l pl
36 Modu³ Crypt::GPG daje prawie ca³kowity dostêp do funkcjonalno¶ci GnuPG
37 poprzez zorientowany obiektowo interfejs. Udostêpnia metody do
38 szyfrowania, odszyfrowywania, podpisywania, weryfikacji podpisów,
39 generowania kluczy, eksportowania i importowania kluczy oraz wielu
40 innych funkcji zwi±zanych z zarz±dzaniem kluczami. Ten modu³ dzia³a
41 prawie identycznie jak jego kuzyn, Crypt::PGP5. Oba modu³y razem daj±
42 jednolity interfejs do obs³ugi PGP i GnuPG. Byæ mo¿e te zostan± one
43 po³±czone w jeden modu³, bêd±cy interfejsem jednocze¶nie do GnuPG i
44 wszystkich wersji PGP.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 perl Makefile.PL
51 %{__make}
52 # test disabled by default - it calls gpg, creates keyring etc.
53 %{?_with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc TODO
67 %{perl_sitelib}/Crypt/GPG.pm
68 %{_mandir}/man3/*
This page took 0.149207 seconds and 3 git commands to generate.