]> git.pld-linux.org Git - packages/perl-Crypt-DES.git/blob - perl-Crypt-DES.spec
- fixed perl-devel BR
[packages/perl-Crypt-DES.git] / perl-Crypt-DES.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    DES
8 Summary:        Crypt::DES - Perl DES encryption module
9 Summary(pl):    Crypt::DES - modu³ Perla dla szyfrowania DES
10 Name:           perl-Crypt-DES
11 Version:        2.03
12 Release:        6
13 License:        BSD-like (see COPYRIGHT)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1b9a84e14214e74e71dd80f906a3db96
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Crypt::DES is Perl interface to DES block cipher.
23
24 %description -l pl
25 Modu³ Perla Crypt::DES zawiera obs³ugê algorytmu szyfrowania DES.
26
27 %prep
28 %setup -q -n %{pdir}-%{pnam}-%{version}
29
30 %build
31 %{__perl} Makefile.PL \
32         INSTALLDIRS=vendor
33 %{__make} \
34         OPTIMIZE="%{rpmcflags}"
35
36 %{?with_tests:%{__make} test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc COPYRIGHT README
50 %{perl_vendorarch}/Crypt/DES.pm
51 %dir %{perl_vendorarch}/auto/Crypt/DES
52 %{perl_vendorarch}/auto/Crypt/DES/DES.bs
53 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/DES/DES.so
54 %{_mandir}/man3/*
This page took 0.040349 seconds and 4 git commands to generate.