]> git.pld-linux.org Git - SPECS.git/blob - perl-Crypt-Camellia.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-Crypt-Camellia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Camellia
7 Summary:        Crypt::Camellia - Crypt::CBC-compliant block cipher
8 Summary(pl.UTF-8):      Crypt::Camellia - szyfr blokowy kompatybilny z Crypt::CBC
9 Name:           perl-Crypt-Camellia
10 Version:        1.0.2
11 Release:        18
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  ba2e8ffa62b22f0cc59c8c867318461a
16 URL:            http://search.cpan.org/dist/Crypt-Camellia/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Camellia is a variable-length key, 128-bit block cipher. It is the
23 NESSIE winner for 128-bit block ciphers. The default key length in
24 this implementation is 128 bits. This module supports the Crypt::CBC
25 interface.
26
27 %description -l pl.UTF-8
28 Camellia to 128-bitowy szyfr blokowy o zmiennej długości klucza. Jest
29 zwycięzcą NESSIE dla 128-bitowych szyfrów blokowych. Domyślny rozmiar
30 klucza w tej implementacji to 128 bitów. Moduł obsługuje interfejs
31 Crypt::CBC.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 cd examples
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 for f in * ; do
54         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
55                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
56 done
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorarch}/Crypt/Camellia.pm
65 %dir %{perl_vendorarch}/auto/Crypt/Camellia
66 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Camellia/Camellia.so
67 %{_mandir}/man3/*
68 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.465151 seconds and 3 git commands to generate.