]> git.pld-linux.org Git - packages/perl-Crypt-CAST5.git/blob - perl-Crypt-CAST5.spec
52a5489561cb28fa94f47fece2f954efb6579a3a
[packages/perl-Crypt-CAST5.git] / perl-Crypt-CAST5.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    CAST5
7 Summary:        Crypt::CAST5 - CAST5 block cipher implementation in C
8 Summary(pl.UTF-8):      Crypt::CAST5 - implementacja szyfru blokowego CAST5 w C
9 Name:           perl-Crypt-CAST5
10 Version:        0.05
11 Release:        21
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f4a876c68885950d5df3c30ede634787
17 URL:            http://search.cpan.org/dist/Crypt-CAST5/
18 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.47}
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides an implementation of the CAST5 block cipher using
25 compiled C code for increased speed. CAST5 is also known as CAST-128.
26 It is a product of the CAST design procedure developed by C. Adams and
27 S. Tavares.
28
29 %description -l pl.UTF-8
30 Ten moduł zawiera implementację szyfru blokowego CAST5 w postaci
31 skompilowanego kodu C, aby zapewnić większą szybkość. CAST5 jest znany
32 także jako CAST-128. Jest to produkt projektu CAST tworzonego przez C.
33 Adamsa i S. Tavaresa.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/Crypt/CAST5.pm
60 %dir %{perl_vendorarch}/auto/Crypt/CAST5
61 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/CAST5/CAST5.so
62 %{_mandir}/man3/Crypt::CAST5.3pm*
This page took 0.096775 seconds and 3 git commands to generate.