]> git.pld-linux.org Git - packages/perl-Crypt-CAST5.git/blob - perl-Crypt-CAST5.spec
- cosmetics
[packages/perl-Crypt-CAST5.git] / perl-Crypt-CAST5.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Crypt
7 %define pnam    CAST5
8 Summary:        Crypt::CAST5 - CAST5 block cipher implementation in C
9 Summary(pl):    Crypt::CAST5 - implementacja szyfru blokowego CAST5 w C
10 Name:           perl-Crypt-CAST5
11 Version:        0.04
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  79806329ad2f39d31e6770a55a89e199
18 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.47}
19 BuildRequires:  perl-devel >= 5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides an implementation of the CAST5 block cipher using
25 compiled C code for increased speed. CAST5 is also known as CAST-128.
26 It is a product of the CAST design procedure developed by C. Adams and
27 S. Tavares.
28
29 %description -l pl
30 Ten modu³ zawiera implementacjê szyfru blokowego CAST5 w postaci
31 skompilowanego kodu C, aby zapewniæ wiêksz± szybko¶æ. CAST5 jest znany
32 tak¿e jako CAST-128. Jest to produkt projektu CAST tworzonego przez
33 C. Adamsa i S. Tavaresa.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/Crypt/CAST5.pm
59 %dir %{perl_vendorarch}/auto/Crypt/CAST5
60 %{perl_vendorarch}/auto/Crypt/CAST5/CAST5.bs
61 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/CAST5/CAST5.so
62 %{_mandir}/man3/*
This page took 0.084908 seconds and 3 git commands to generate.