]> git.pld-linux.org Git - packages/perl-Coro.git/blob - perl-Coro.spec
- updated BRs, added versioned runtime dependencies
[packages/perl-Coro.git] / perl-Coro.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Coro
7 %define         pnam    Coro
8 Summary:        Coro - do events the coro-way
9 Summary(pl.UTF-8):      Coro - obsługa zdarzeń na sposób coro
10 Name:           perl-Coro
11 Version:        6.31
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  519e3304e86ed103c167b299ab94c176
18 Patch0:         kill-blocked-test.patch
19 URL:            http://search.cpan.org/dist/Coro/
20 BuildRequires:  perl-AnyEvent >= 2:5.0
21 BuildRequires:  perl-EV >= 1:4.0
22 BuildRequires:  perl-Event >= 1.08
23 BuildRequires:  perl-devel >= 1:5.8.2
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  sed >= 4.0
26 %if %{with tests}
27 BuildRequires:  perl-AnyEvent-Impl-EV
28 BuildRequires:  perl-AnyEvent-Impl-Event
29 BuildRequires:  perl-Guard >= 0.5
30 BuildRequires:  perl-Storable >= 2.15
31 BuildRequires:  perl-Time-HiRes
32 BuildRequires:  perl-common-sense
33 %endif
34 Requires:       perl-AnyEvent >= 2:5.0
35 Requires:       perl-BDB >= 1.5
36 Requires:       perl-EV >= 1:4.0
37 Requires:       perl-Guard >= 0.5
38 Requires:       perl-Storable >= 2.15
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 This module enables you to create programs using the powerful Event
43 model (and module), while retaining the linear style known from simple
44 or threaded programs.
45
46 %description -l pl.UTF-8
47 Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
48 (i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
49 wątkowych programów.
50
51 %prep
52 %setup -q -n %{pnam}-%{version}
53 %patch0 -p1
54
55 %{__sed} -i "s^/opt/bin/perl^%{_bindir}/perl^" Coro/jit*pl
56
57 %build
58 echo "y" | %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make} \
61         CC="%{__cc}" \
62         OPTIMIZE="%{rpmcflags}"
63
64 %{?with_tests:%{__make} -j1 test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc COPYING Changes INSTALL README README.linux-glibc
78 %{perl_vendorarch}/Coro.pm
79 %{perl_vendorarch}/Coro
80 %dir %{perl_vendorarch}/auto/Coro
81 %dir %{perl_vendorarch}/auto/Coro/EV
82 %{perl_vendorarch}/auto/Coro/EV/EV.bs
83 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/EV/EV.so
84 %dir %{perl_vendorarch}/auto/Coro/Event
85 %{perl_vendorarch}/auto/Coro/Event/Event.bs
86 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/Event.so
87 %dir %{perl_vendorarch}/auto/Coro/State
88 %{perl_vendorarch}/auto/Coro/State/State.bs
89 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/State.so
90 %{_mandir}/man3/Coro*.3pm*
This page took 0.038922 seconds and 4 git commands to generate.