]> git.pld-linux.org Git - packages/perl-Coro.git/blob - perl-Coro.spec
- rel 4; BR perl-Event
[packages/perl-Coro.git] / perl-Coro.spec
1 # NOTE:         perl-AnyEvent requires perl(Core::{Event,Signal})
2 #
3 # Conditional build:
4 %bcond_without  tests   # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Coro
8 %define         pnam    Coro
9 Summary:        Coro - do events the coro-way
10 Summary(pl.UTF-8):      Coro - obsługa zdarzeń na sposób coro
11 Name:           perl-Coro
12 Version:        4.34
13 Release:        4
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Coro/%{pnam}-%{version}.tar.gz
18 # Source0-md5:  61ee3d551a03286288c6c428e5bd5d23
19 URL:            http://search.cpan.org/dist/Coro/
20 BuildRequires:  perl-AnyEvent >= 2.7
21 BuildRequires:  perl-Event
22 BuildRequires:  perl-IO-AIO
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module enables you to create programs using the powerful Event
29 model (and module), while retaining the linear style known from simple
30 or threaded programs.
31
32 %description -l pl.UTF-8
33 Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
34 (i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
35 wątkowych programów.
36
37 %prep
38 %setup -q -n %{pnam}-%{version}
39
40 %build
41 echo "y
42 l
43 16384" | %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes INSTALL README README.linux-glibc
63 %{perl_vendorarch}/Coro.pm
64 %{perl_vendorarch}/Coro
65 %dir %{perl_vendorarch}/auto/Coro
66 %dir %{perl_vendorarch}/auto/Coro/Event
67 %dir %{perl_vendorarch}/auto/Coro/State
68 %{perl_vendorarch}/auto/Coro/Event/*.bs
69 %{perl_vendorarch}/auto/Coro/State/*.bs
70 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/*.so
71 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/*.so
72 %{_mandir}/man3/*
This page took 0.085307 seconds and 4 git commands to generate.