]> git.pld-linux.org Git - packages/perl-Coro.git/blob - perl-Coro.spec
e14ec52f7a47bb70eeb74149b26c7f28a60c13a5
[packages/perl-Coro.git] / perl-Coro.spec
1 # NOTE:         perl-AnyEvent requires perl(Core::{Event,Signal})
2 #
3 # Conditional build:
4 %bcond_without  tests   # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Coro
8 %define         pnam    Coro
9 Summary:        Coro - do events the coro-way
10 Summary(pl.UTF-8):      Coro - obsługa zdarzeń na sposób coro
11 Name:           perl-Coro
12 Version:        6.06
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
18 # Source0-md5:  2ee54f58bced7471f77149e97c73a94f
19 Patch0:         kill-blocked-test.patch
20 URL:            http://search.cpan.org/dist/Coro/
21 BuildRequires:  perl-AnyEvent >= 2:5.0
22 BuildRequires:  perl-EV >= 1:3.3
23 BuildRequires:  perl-Event >= 1.08
24 BuildRequires:  perl-devel >= 1:5.8.2
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 %if %{with tests}
27 BuildRequires:  perl-Guard >= 0.5
28 BuildRequires:  perl-Storable >= 2.15
29 BuildRequires:  perl-Time-HiRes
30 BuildRequires:  perl-common-sense
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This module enables you to create programs using the powerful Event
36 model (and module), while retaining the linear style known from simple
37 or threaded programs.
38
39 %description -l pl.UTF-8
40 Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
41 (i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
42 wątkowych programów.
43
44 %prep
45 %setup -q -n %{pnam}-%{version}
46 %patch0 -p1
47
48 %build
49 echo "y" | %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} -j1 test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes INSTALL README README.linux-glibc
69 %{perl_vendorarch}/Coro.pm
70 %{perl_vendorarch}/Coro
71 %dir %{perl_vendorarch}/auto/Coro
72 %dir %{perl_vendorarch}/auto/Coro/EV
73 %{perl_vendorarch}/auto/Coro/EV/EV.bs
74 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/EV/EV.so
75 %dir %{perl_vendorarch}/auto/Coro/Event
76 %{perl_vendorarch}/auto/Coro/Event/Event.bs
77 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/Event.so
78 %dir %{perl_vendorarch}/auto/Coro/State
79 %{perl_vendorarch}/auto/Coro/State/State.bs
80 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/State.so
81 %{_mandir}/man3/Coro*.3pm*
This page took 0.059982 seconds and 2 git commands to generate.