]> git.pld-linux.org Git - packages/perl-Coro.git/blob - perl-Coro.spec
- converted to UTF-8
[packages/perl-Coro.git] / perl-Coro.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Coro
7 %define         pnam    Coro
8 Summary:        Coro - do events the coro-way
9 Summary(pl.UTF-8):   Coro - obsługa zdarzeń na sposób coro
10 Name:           perl-Coro
11 Version:        3.41
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d294dde59c19e22fa63a23d6c9dd9580
18 Patch0:         %{pnam}-libc.patch
19 URL:            http://search.cpan.org/dist/Coro/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module enables you to create programs using the powerful Event
26 model (and module), while retaining the linear style known from simple
27 or threaded programs.
28
29 %description -l pl.UTF-8
30 Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
31 (i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
32 wątkowych programów.
33
34 %prep
35 %setup -q -n %{pnam}-%{version}
36 %patch0 -p1
37
38 %build
39 echo "y
40 l
41 16384" | %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes INSTALL README README.linux-glibc
60 %{perl_vendorarch}/Coro.pm
61 %{perl_vendorarch}/Coro
62 %dir %{perl_vendorarch}/auto/Coro
63 %dir %{perl_vendorarch}/auto/Coro/Event
64 %dir %{perl_vendorarch}/auto/Coro/State
65 %{perl_vendorarch}/auto/Coro/Event/*.bs
66 %{perl_vendorarch}/auto/Coro/State/*.bs
67 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/*.so
68 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/*.so
69 %{_mandir}/man3/*
This page took 0.062778 seconds and 3 git commands to generate.