]> git.pld-linux.org Git - SPECS.git/blob - perl-Convert-GeekCode.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / perl-Convert-GeekCode.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Convert
6 %define         pnam    GeekCode
7 Summary:        Convert::GeekCode - convert and generate geek code sequences
8 Summary(pl.UTF-8):      Convert::GeekCode - generowanie i konwersja sekwencji ,,geek code''
9 Name:           perl-Convert-GeekCode
10 Version:        0.62
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  33db901752d33da513aa0b24f1e26db5
17 URL:            http://search.cpan.org/dist/Convert-GeekCode/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-YAML
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Convert::GeekCode converts and generates Geek Code sequences (cf.
28 http://geekcode.com/). It supports different langugage codes and
29 user-customizable codesets.
30
31 %description -l pl.UTF-8
32 Moduł Convert::GeekCode konwertuje i generuje sekwencje Geek Code
33 (http://geekcode.com/). Obsługuje kody dla różnych języków i zestawy
34 kodów definiowane przez użytkownika.
35
36 %package -n geekcode-tools
37 Summary:        geekdec - Geek Code decoder, geekgen - Geek Code generator
38 Summary(pl.UTF-8):      geekdec - dekoder i geekgen - generator Geek Code
39 Group:          Applications
40 Requires:       %{name}
41
42 %description -n geekcode-tools
43 geekdec parses Geek Code sequences read from the standard input, and
44 prints out explanations.
45
46 geekgen generates Geek Code sequences interactively, according to
47 user's input. User could mix numerical selections with usual symbols
48 like (), >, ! and @.
49
50 %description -n geekcode-tools -l pl.UTF-8
51 geekdec analizuje sekwencje Geek Code czytane ze standardowego wyjścia
52 i wypisuje ich znaczenie.
53
54 geekgen generuje sekwencje Geek Code interaktywnie, zgodnie z danymi
55 wprowadzanymi przez użytkownika. Użytkownik może mieszać numery opcji
56 ze zwykle używanymi symbolami takimi jak (), >, ! i @.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %{perl_vendorlib}/%{pdir}/*.pm
80 %{perl_vendorlib}/%{pdir}/%{pnam}
81 %{_mandir}/man3/*
82
83 %files -n geekcode-tools
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/*
86 %{_mandir}/man1/*
This page took 0.085788 seconds and 3 git commands to generate.