]> git.pld-linux.org Git - packages/perl-Class-XPath.git/blob - perl-Class-XPath.spec
- license fixes and unification
[packages/perl-Class-XPath.git] / perl-Class-XPath.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Class
7 %define pnam    XPath
8 Summary:        Class::XPath - module that adds XPath matching to object trees
9 Summary(pl):    Class::XPath - modu³ dodaj±cy dopasowywanie XPath do drzew obiektów
10 Name:           perl-Class-XPath
11 Version:        1.4
12 Release:        1
13 # same as perl 5
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  22ff3d2536027f3a9f59c6eb849fa610
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module adds XPath-style matching to your object trees. This means
25 that you can find nodes using an XPath-esque query with "match()" from
26 anywhere in the tree. Also, the "xpath()" method returns a unique path
27 to a given node which can be used as an identifier.
28
29 %description -l pl
30 Ten modu³ dodaje dopasowywanie w stylu XPath do drzew obiektów.
31 Oznacza to, ¿e mo¿na szukaæ wêz³ów przy u¿yciu zapytania typu XPath
32 funkcj± "match()" z ka¿dego miejsca w drzewie. Ponadto metoda
33 "xpath()" zwraca unikaln± ¶cie¿kê do danego wêz³a, któr± mo¿na u¿ywaæ
34 jako identyfikator.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/Class/XPath.pm
60 %{_mandir}/man3/*
This page took 0.068576 seconds and 3 git commands to generate.