]> git.pld-linux.org Git - packages/perl-Class-Unload.git/blob - perl-Class-Unload.spec
696612e9feb2c330ed99f93e15a865c18f354cd6
[packages/perl-Class-Unload.git] / perl-Class-Unload.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    Unload
7 Summary:        Class::Unload - Unload a class
8 Name:           perl-Class-Unload
9 Version:        0.11
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  0c28497de640aea4c3900fb52b7c6cb5
16 URL:            http://search.cpan.org/dist/Class-Unload/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Class-Inspector
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Unloads the given class by clearing out its symbol table and removing
27 it from INC hash.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %{__make} pure_install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc Changes
50 %{perl_vendorlib}/Class/*.pm
51 %{_mandir}/man3/*
This page took 0.056148 seconds and 2 git commands to generate.