]> git.pld-linux.org Git - SPECS.git/blob - perl-CatalystX-ListFramework.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-CatalystX-ListFramework.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %define pdir    CatalystX
6 %define pnam    ListFramework
7 Summary:        CatalystX::ListFramework - foundations for displaying and editing lists (CRUD) in a Catalyst application
8 #Summary(pl.UTF-8):     
9 Name:           perl-CatalystX-ListFramework
10 Version:        0.5
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CatalystX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e9a93c059a250e8c4865c59cd8a63693
17 URL:            http://search.cpan.org/dist/CatalystX-ListFramework/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Catalyst::View::JSON)
22 BuildRequires:  perl(DBD::SQLite2)
23 BuildRequires:  perl(HTML::Widget)
24 BuildRequires:  perl(Test::WWW::Mechanize::Catalyst)
25 BuildRequires:  perl-Catalyst
26 BuildRequires:  perl-Catalyst-Plugin-HTML-Widget
27 BuildRequires:  perl-Catalyst-Plugin-StackTrace
28 BuildRequires:  perl-Test-use-ok
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Displaying tabulated lists of database records, updating those records and
35 creating new ones is a common task in Catalyst applications.
36 This class supplies such lists, and forms to edit such records, to a set of
37 templates, using simple definition files and your DBIx::Class Catalyst
38 model. A search form is also supplied, which can include JSON-powered
39 ExtJS comboboxes (see http://www.extjs.com/).
40
41 # %description -l pl.UTF-8
42 # TODO
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes TODO
66 %{perl_vendorlib}/CatalystX/*.pm
67 %{perl_vendorlib}/CatalystX/ListFramework
68 %{_mandir}/man3/*
This page took 0.55341 seconds and 3 git commands to generate.