]> git.pld-linux.org Git - SPECS.git/blob - perl-Catalyst-Engine-Apache.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / perl-Catalyst-Engine-Apache.spec
1 #
2 # Sorry, only Apache2 version...
3 #
4 # Conditional build:
5 %bcond_without  tests           # do not perform "make test"
6 #
7 %define pdir    Catalyst
8 %define pnam    Engine-Apache
9 Summary:        Catalyst::Engine::Apache - Catalyst Apache Engines
10 Summary(pl.UTF-8):      Catalyst::Engine::Apache - silniki Apache'a dla Catalysta
11 Name:           perl-Catalyst-Engine-Apache
12 Version:        1.16
13 Release:        1
14 Epoch:          1
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/Catalyst/%{pdir}-%{pnam}-%{version}.tar.gz
19 # Source0-md5:  7a7241dadd7c0eb28ce10aeb90c9944e
20 URL:            http://search.cpan.org/dist/Catalyst-Engine-Apache/
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Catalyst >= 5.49_02
25 %endif
26 Conflicts:      perl-Catalyst < 5.49
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 These classes provide mod_perl (Apache 2) support for Catalyst.
32
33 %description -l pl.UTF-8
34 Ten pakiet zawiera silnik Catalysta wykorzystujÄ…cy mod_perla
35 (Apache 2.x).
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 # Makefile.PL turns on only t/0*.t; we're running all, and one test depends on this file
41 if [ ! -e t/01use.t ]; then
42 cat <<EOF>t/01use.t
43         use Test::More tests=>1;
44         ok(1);
45 EOF
46 fi
47
48 %build
49 %{__perl} -MExtUtils::MakeMaker -we 'WriteMakefile(NAME=>"Catalyst::Engine::Apache")' \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/Catalyst/Engine/*.pm
68 %dir %{perl_vendorlib}/Catalyst/Engine/Apache2
69 %{perl_vendorlib}/Catalyst/Engine/Apache2/MP20.pm
70 %exclude %{_mandir}/man3/*MP19*
71 %{_mandir}/man3/Catalyst::Engine::Apache.*
72 %{_mandir}/man3/Catalyst::Engine::Apache2*
This page took 0.117166 seconds and 3 git commands to generate.