]> git.pld-linux.org Git - packages/perl-Carp-Assert.git/blob - perl-Carp-Assert.spec
- BR: perl-devel; do not BR: perl
[packages/perl-Carp-Assert.git] / perl-Carp-Assert.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Carp
7 %define         pnam    Assert
8 Summary:        Carp::Assert - executable comments
9 Summary(pl):    Carp::Assert - wykonywalne komentarze
10 Name:           perl-Carp-Assert
11 Version:        0.17
12 Release:        9
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl-devel >= 5.6.1
17 %{!?_without_tests:BuildRequires:       perl-Test-Simple >= 0.18}
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Carp::Assert is intended for a purpose like the ANSI C library
24 assert.h. An assertion is used to prevent the impossible from being
25 asked of your code, or at least tell you when it does.
26
27 %description -l pl
28 Modu³ Carp::Assert s³u¿y do tego, co assert.h z ANSI C. U¿ywa siê
29 zapewnieñ (assertion), aby wykluczyæ wystêpowanie rzeczy niemo¿liwych,
30 albo przynajmniej wiedzieæ, gdzie siê zdarzaj±.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor 
38 %{__make}
39
40 %{!?_without_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes README
53 %{perl_vendorlib}/Carp
54 %{_mandir}/man3/*
This page took 0.146802 seconds and 4 git commands to generate.