]> git.pld-linux.org Git - packages/perl-Carp-Assert.git/blob - perl-Carp-Assert.spec
- license fixes and unification
[packages/perl-Carp-Assert.git] / perl-Carp-Assert.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Carp
7 %define         pnam    Assert
8 Summary:        Carp::Assert - executable comments
9 Summary(pl):    Carp::Assert - wykonywalne komentarze
10 Name:           perl-Carp-Assert
11 Version:        0.18
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8137794654f5802730c05167327d496e
18 BuildRequires:  perl-devel >= 5.6.1
19 %{!?_without_tests:BuildRequires:       perl-Test-Simple >= 0.18}
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Carp::Assert is intended for a purpose like the ANSI C library
26 assert.h. An assertion is used to prevent the impossible from being
27 asked of your code, or at least tell you when it does.
28
29 %description -l pl
30 Modu³ Carp::Assert s³u¿y do tego, co assert.h z ANSI C. U¿ywa siê
31 zapewnieñ (assertion), aby wykluczyæ wystêpowanie rzeczy niemo¿liwych,
32 albo przynajmniej wiedzieæ, gdzie siê zdarzaj±.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{!?_without_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/Carp
56 %{_mandir}/man3/*
This page took 0.086393 seconds and 4 git commands to generate.