]> git.pld-linux.org Git - packages/perl-Cache-Cache.git/blob - perl-Cache-Cache.spec
- BR: perl-devel; do not BR: perl
[packages/perl-Cache-Cache.git] / perl-Cache-Cache.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Cache
7 %define         pnam    Cache
8 Summary:        Cache::Cache perl extension
9 Summary(pl):    Rozszerzenie perla: Cache::Cache
10 Name:           perl-Cache-Cache
11 Version:        1.01
12 Release:        5
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 URL:            http://perl-cache.sourceforge.net/
17 BuildRequires:  perl-devel >= 5.6.1
18 %if %{?_without_tests:0}%{!?_without_tests:1}
19 BuildRequires:  perl-Digest-SHA1 >= 2.01
20 BuildRequires:  perl-Error >= 0.15
21 BuildRequires:  perl(File::Spec) >= 0.82
22 BuildRequires:  perl-IPC-ShareLite >= 0.08
23 BuildRequires:  perl-Storable >= 1.014
24 %endif
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Cache modules are designed to assist a developer in persisting
31 data for a specified period of time. Often these modules are used
32 in web applications to store data locally to save repeated and
33 redundant expensive calls to remote machines or databases. People
34 have also been known to use Cache::Cache for its straightforward
35 interface in sharing data between runs of an application or
36 invocations of a CGI-style script or simply as an easy to use
37 abstraction of the filesystem or shared memory.
38
39 %description -l pl
40 Modu³y Cache maj± na celu pomóc programi¶cie w utrzymywaniu danych
41 przez okre¶lony czas. Te modu³y s± przewa¿nie u¿ywane w aplikacjach
42 WWW do zapisywania danych lokalnie w celu unikniêcia powtarzaj±cych
43 siê i niepotrzebnych odwo³añ do zewnêtrznych maszyn lub baz danych.
44 Cache::Cache bywa u¿ywany ze wzglêdu na swój prosty interfejs do
45 dzielenia danych pomiêdzy uruchomieniami aplikacji lub wywo³aniami
46 skryptu CGI, albo po prostu jako ³atwa w u¿yciu abstrakcja systemu
47 plików lub pamiêci dzielonej.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} -MExtUtils::MakeMaker -wle 'WriteMakefile(NAME=>"Cache::Cache")' \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{!?_without_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc CHANGES COPYING CREDITS DISCLAIMER README STYLE
70 %{perl_vendorlib}/Cache/*.pm
71 %{_mandir}/man3/*
This page took 0.063627 seconds and 4 git commands to generate.