]> git.pld-linux.org Git - packages/perl-Cache-Cache.git/blob - perl-Cache-Cache.spec
- fixed perl-devel BR
[packages/perl-Cache-Cache.git] / perl-Cache-Cache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Cache
7 %define         pnam    Cache
8 Summary:        Cache::Cache - a generic interface for creating persistent data stores
9 Summary(pl):    Cache::Cache - ogólny interfejs do trwa³ego przechowywania danych
10 Name:           perl-Cache-Cache
11 Version:        1.02
12 Release:        1
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9dfff47f2317a59a15546a972b2a67ba
17 URL:            http://perl-cache.sourceforge.net/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Digest-SHA1 >= 2.01
21 BuildRequires:  perl-Error >= 0.15
22 BuildRequires:  perl(File::Spec) >= 0.82
23 BuildRequires:  perl-IPC-ShareLite >= 0.08
24 BuildRequires:  perl-Storable >= 1.014
25 %endif
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Cache modules are designed to assist a developer in persisting
32 data for a specified period of time. Often these modules are used
33 in web applications to store data locally to save repeated and
34 redundant expensive calls to remote machines or databases. People
35 have also been known to use Cache::Cache for its straightforward
36 interface in sharing data between runs of an application or
37 invocations of a CGI-style script or simply as an easy to use
38 abstraction of the filesystem or shared memory.
39
40 %description -l pl
41 Modu³y Cache maj± na celu pomóc programi¶cie w utrzymywaniu danych
42 przez okre¶lony czas. Te modu³y s± przewa¿nie u¿ywane w aplikacjach
43 WWW do zapisywania danych lokalnie w celu unikniêcia powtarzaj±cych
44 siê i niepotrzebnych odwo³añ do zewnêtrznych maszyn lub baz danych.
45 Cache::Cache bywa u¿ywany ze wzglêdu na swój prosty interfejs do
46 dzielenia danych pomiêdzy uruchomieniami aplikacji lub wywo³aniami
47 skryptu CGI, albo po prostu jako ³atwa w u¿yciu abstrakcja systemu
48 plików lub pamiêci dzielonej.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} -MExtUtils::MakeMaker -wle 'WriteMakefile(NAME=>"Cache::Cache")' \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc CHANGES COPYING CREDITS DISCLAIMER README STYLE
72 %{perl_vendorlib}/Cache/*.pm
73 %{_mandir}/man3/*
This page took 0.219558 seconds and 3 git commands to generate.