]> git.pld-linux.org Git - packages/perl-CPAN.git/blob - perl-CPAN.spec
- use the __perl macro
[packages/perl-CPAN.git] / perl-CPAN.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    CPAN
7 Summary:        CPAN Perl module - query, download and build Perl modules from CPAN sites
8 Summary(pl):    Modu³ Perla CPAN - odpytywanie, ¶ci±ganie i budowanie modu³ów Perla z serwisów CPAN
9 Name:           perl-CPAN
10 Version:        1.65
11 Release:        1
12 License:        ?
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
15 %if %{?_without_tests:0}%{!?_without_tests:1}
16 BuildRequires:  perl(File::Spec)
17 BuildRequires:  perl-Test-Simple
18 %endif
19 BuildRequires:  rpm-perlprov
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The CPAN module is designed to automate the make and install of perl
25 modules and extensions. It includes some searching capabilities and
26 knows how to use Net::FTP or LWP (or lynx or an external ftp client)
27 to fetch the raw data from the net.
28
29 %description -l pl
30 Modu³ CPAN s³u¿y do automatyzacji procesu budowania i instalowania
31 modu³ów i rozszerzeñ Perla. Ma mo¿liwo¶æ wyszukiwania i u¿ywania
32 Net::FTP lub LWP (albo lynksa czy zewnêtrznego klienta ftp) do
33 ¶ci±gania danych z sieci.
34
35 %prep
36 %setup -q -n %{pdir}-%{version}
37
38 %build
39 %{__perl} Makefile.PL
40 %{__make}
41
42 %{!?_without_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc ChangeLog Todo
55 %attr(755,root,root) %{_bindir}/cpan
56 %{perl_privlib}/*.pm
57 %{perl_privlib}/%{pdir}/*.pm
58 %{_mandir}/man1/*
59 %{_mandir}/man3/C*
This page took 0.100378 seconds and 4 git commands to generate.