]> git.pld-linux.org Git - packages/perl-CPAN.git/blob - perl-CPAN.spec
4a48e79e424556e5266d8effec8a26d95c5ffaa0
[packages/perl-CPAN.git] / perl-CPAN.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CPAN
7 Summary:        CPAN Perl module - query, download and build Perl modules from CPAN sites
8 Summary(pl.UTF-8):      Moduł Perla CPAN - odpytywanie, ściąganie i budowanie modułów Perla z serwisów CPAN
9 Name:           perl-CPAN
10 Version:        1.9301
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  291ef4d76121718d6ebad25fcde40395
17 URL:            http://search.cpan.org/dist/CPAN/
18 %if %{with tests}
19 BuildRequires:  perl-Test-Simple
20 %endif
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The CPAN module is designed to automate the make and install of perl
28 modules and extensions. It includes some searching capabilities and
29 knows how to use Net::FTP or LWP (or lynx or an external FTP client)
30 to fetch the raw data from the net.
31
32 %description -l pl.UTF-8
33 Moduł CPAN służy do automatyzacji procesu budowania i instalowania
34 modułów i rozszerzeń Perla. Ma możliwość wyszukiwania i używania
35 Net::FTP lub LWP (albo lynksa czy zewnętrznego klienta FTP) do
36 ściągania danych z sieci.
37
38 %prep
39 %setup -q -n %{pdir}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc ChangeLog Todo
60 %attr(755,root,root) %{_bindir}/cpan
61 %{perl_vendorlib}/*.pm
62 %dir %{perl_vendorlib}/CPAN
63 %{perl_vendorlib}/CPAN/*.pm
64 %{_mandir}/man1/*
65 %{_mandir}/man3/C*
This page took 0.072453 seconds and 3 git commands to generate.