]> git.pld-linux.org Git - packages/perl-CGI.git/blob - perl-CGI.spec
- up to 2.99 (fixes XSS vulnerability)
[packages/perl-CGI.git] / perl-CGI.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CGI
7 %define         pnam    CGI
8 Summary:        CGI Perl module
9 Summary(cs):    Modul CGI pro Perl
10 Summary(da):    Perlmodul CGI
11 Summary(de):    CGI Perl Modul
12 Summary(es):    Módulo de Perl CGI
13 Summary(fr):    Module Perl CGI
14 Summary(it):    Modulo di Perl CGI
15 Summary(ja):    CGI Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    CGI ÆÞ ¸ðÁÙ
17 Summary(no):    Perlmodul CGI
18 Summary(pl):    Modu³ Perla CGI
19 Summary(pt):    Módulo de Perl CGI
20 Summary(pt_BR): Módulo Perl CGI
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl CGI
22 Summary(sv):    CGI Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl CGI
24 Summary(zh_CN): CGI Perl Ä£¿é
25 Name:           perl-CGI
26 Version:        2.99
27 Release:        1
28 Epoch:          1
29 License:        GPL/Artistic
30 Group:          Development/Languages/Perl
31 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}.pm-%{version}.tar.gz
32 # Source0-md5:  8f12c0d0462409ab33447a44dbaefe2b
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  perl-devel
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreq      'perl(FCGI)' 'perl(Apache) 'perl(Apache::compat)' 'perl(mod_perl)'
39
40 %description
41 CGI is an easy-to-use Perl5 library for writing World Wide Web CGI
42 scripts. This is replacement for usually outdated CGI module from perl
43 distribution.
44
45 %description -l pl
46 CGI jest modu³em to prostego i szybkiego pisania aplikacji dla WWW -
47 skryptów CGI. Pakiet ten zawiera zamiennik dla zazwyczaj starej wersji
48 modu³u CGI która jest dostarczana razem z perlem.
49
50 %package examples
51 Summary:        Examples for the CGI module
52 Summary(pl):    Przyk³ady u¿ycia modu³u CGI
53 Group:          Development/Languages/Perl
54 Requires:       %{name} = %{epoch}:%{version}
55
56 %description examples
57 Examples for the CGI module.
58
59 %description examples -l pl
60 Przyk³ady u¿ycia modu³u CGI.
61
62 %prep
63 %setup -q -n %{pnam}.pm-%{version}
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor 
68 %{__make}
69
70 %{!?_without_tests:%{__make} test}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 install -d $RPM_BUILD_ROOT%{_examplesdir}
79 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc Changes README *.html
87 %{perl_vendorlib}/CGI.pm
88 %{perl_vendorlib}/CGI/*
89 %{_mandir}/man3/*
90
91 %files examples
92 %defattr(644,root,root,755)
93 %dir %{_examplesdir}/%{name}-%{version}
94 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.cgi
95 %{_examplesdir}/%{name}-%{version}/*.[!c]*
96 %{_examplesdir}/%{name}-%{version}/WORLD*
This page took 0.027523 seconds and 3 git commands to generate.