]> git.pld-linux.org Git - packages/perl-CGI-Simple.git/blob - perl-CGI-Simple.spec
8e166eafe63827b74cf0a031da0a0aa79556638a
[packages/perl-CGI-Simple.git] / perl-CGI-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    CGI
7 %define pnam    Simple
8 Summary:        CGI::Simple - a Simple totally OO CGI interface that is CGI.pm compliant
9 Summary(pl.UTF-8):      CGI::Simple - prosty, zorientowany obiektowo interfejs CGI zgodny z CGI.pm
10 Name:           perl-CGI-Simple
11 Version:        1.113
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  50c50dbec87b822e3f2285e41cb23519
18 URL:            http://search.cpan.org/dist/Cgi-Simple/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-IO-stringy
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 CGI::Simple provides a relatively lightweight drop in replacement for
30 CGI.pm. It shares an identical OO interface to CGI.pm for parameter
31 parsing, file upload, cookie handling and header generation. This
32 module is entirely object oriented, however a complete functional
33 interface is available by using the CGI::Simple::Standard module.
34
35 %description -l pl.UTF-8
36 CGI::Simple udostępnia w miarę lekki zamiennik CGI.pm. Współdzieli z
37 CGI.pm identyczny zorientowany obiektowo interfejs do analizy
38 parametrów, przesyłania plików, obsługi ciasteczek i generowania
39 nagłówków. Ten moduł jest w pełni zorientowany obiektowo, ale z
40 pełnym interfejsem funkcyjnym dostępnym poprzez moduł
41 CGI::Simple::Standard.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45 #setup -q -n Cgi-%{pnam}-%{version}
46
47 %build
48 %{__perl} Build.PL \
49         destdir=$RPM_BUILD_ROOT \
50         installdirs=vendor
51 ./Build
52
53 %{?with_tests:./Build test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 ./Build install
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/CGI/*.pm
67 %{perl_vendorlib}/CGI/Simple
68 %{_mandir}/man3/*
This page took 0.067865 seconds and 3 git commands to generate.