]> git.pld-linux.org Git - packages/perl-CGI-FastTemplate.git/blob - perl-CGI-FastTemplate.spec
use generic url
[packages/perl-CGI-FastTemplate.git] / perl-CGI-FastTemplate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    FastTemplate
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CGI::FastTemplate - Perl extension for managing templates, and performing variable interpolation
9 Summary(pl.UTF-8):      CGI::FastTemplate - rozszerzenie Perla do zarządzania wzorcami i zastępowania zmiennych
10 Name:           perl-CGI-FastTemplate
11 Version:        1.09
12 Release:        10
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c5fe8ead04c525c8d5633c9453af802f
18 URL:            http://search.cpan.org/dist/CGI-FastTemplate/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 CGI::FastTemplate Perl module manages templates and parses templates
26 replacing variable names with values.
27
28 %description -l pl.UTF-8
29 Moduł Perla CGI::FastTemplate zarządza wzorcami i analizuje je,
30 zastępując przy tym nazwy zmiennych wartościami.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README templates
54 %{perl_vendorlib}/CGI/FastTemplate.pm
55 %{_mandir}/man3/*
This page took 0.132333 seconds and 3 git commands to generate.