]> git.pld-linux.org Git - SPECS.git/blob - perl-CDB-TinyCDB.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-CDB-TinyCDB.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4
5 %define         pdir    CDB
6 %define         pnam    TinyCDB
7 Summary:        CDB::TinyCDB - Perl extension for TinyCDB library to cdb databases
8 Name:           perl-CDB-TinyCDB
9 Version:        0.05
10 Release:        3
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/A/AJ/AJGB/CDB-TinyCDB-%{version}.tar.gz
15 # Source0-md5:  e77702b031264c6686a6f617e92b9e24
16 URL:            https://metacpan.org/release/CDB-TinyCDB/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  tinycdb-devel
20 %if %{with tests}
21 BuildRequires:  perl-Test-Exception
22 BuildRequires:  perl-Test-NoWarnings
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 CDB::TinyCDB is a Perl extension for TinyCDB library to query and
28 create CDB files.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make} \
37         CC="%{__cc}" \
38         OPTIMIZE="%{rpmcflags}"
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes README
53 %dir %{perl_vendorarch}/CDB
54 %{perl_vendorarch}/CDB/TinyCDB.pm
55 %dir %{perl_vendorarch}/auto/CDB
56 %dir %{perl_vendorarch}/auto/CDB/TinyCDB
57 %attr(755,root,root) %{perl_vendorarch}/auto/CDB/TinyCDB/TinyCDB.so
58 %{_mandir}/man3/CDB::TinyCDB.3pm*
This page took 0.435097 seconds and 3 git commands to generate.