]> git.pld-linux.org Git - SPECS.git/blob - perl-B-Debug.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / perl-B-Debug.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    B
6 %define         pnam    Debug
7 Summary:        B::Debug - walk Perl syntax tree, printing debug info about ops
8 Summary(pl.UTF-8):      B::Debug - przejście po drzewie składniowym Perla z wypisywaniem informacji o operacjach
9 Name:           perl-B-Debug
10 Version:        1.26
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/B/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  260ec0e2c2b18af1d42911bfaf6b7477
17 URL:            https://metacpan.org/release/B-Debug
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Walk Perl syntax tree, printing debug info about ops.
26
27 %description -l pl.UTF-8
28 Przejście po drzewie składniowym Perla z wypisywaniem informacji
29 diagnostycznych o operacjach.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes README
53 %{perl_vendorlib}/B/Debug.pm
54 %{_mandir}/man3/B::Debug.3pm*
This page took 0.283839 seconds and 3 git commands to generate.