]> git.pld-linux.org Git - packages/perl-Astro-FITS-CFITSIO.git/blob - perl-Astro-FITS-CFITSIO.spec
9a444b99c782d0a1249177518329624e539fa3b0
[packages/perl-Astro-FITS-CFITSIO.git] / perl-Astro-FITS-CFITSIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Astro
7 %define         pnam    FITS-CFITSIO
8 Summary:        Astro::FITS::CFITSIO - Perl extension for using the cfitsio library
9 Summary(pl):    Astro::FITS::CFITSIO - rozszerzenie Perla do korzystania z biblioteki cfitsio
10 Name:           perl-Astro-FITS-CFITSIO
11 Version:        1.01
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  75f7757350c9fc1a3775811e111a74d4
18 BuildRequires:  cfitsio-devel >= 2.400
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Astro::FITS::CFITSIO is a Perl interface to William Pence's cfitsio
25 subroutine library.
26  
27 This module attempts to provide a wrapper for nearly every cfitsio
28 routine, while retaining as much cfitsio behavior as possible. As
29 such, one should be aware that it is still somewhat low-level, in the
30 sense that handing an array which is not the correct size to a routine
31 like fits_write_img() may cause SIGSEGVs.
32
33 The goal is to eventually use these routines to build a more Perl-like
34 interface to many common tasks such as reading and writing of images
35 and ASCII and binary tables.
36
37 %description -l pl
38 Astro::FITS::CFITSIO jest perlowym interfejsem do biblioteki cfitsio
39 Williama Pence'a.
40
41 Ten modu³ jest prób± dostarczenia obudowania dla prawie wszystkich
42 funkcji cfitsio przy zachowaniu mo¿liwie najbli¿szym cfitsio. Przez to
43 trzeba mieæ na uwadze, ¿e dostêp jest nieco niskopoziomowy, w tym
44 sensie, ¿e przekazanie tablicy o z³ym rozmiarze do funkcji typu
45 fits_write_img() mo¿e powodowaæ SIGSEGV.
46
47 Celem autora jest ewentualne wykorzystanie tych funkcji to stworzenia
48 bardziej perlowego interfejsu do wielu ogólnych zadañ, takich jak
49 odczyt i zapis obrazów oraz tablic binarnych i ASCII.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc ChangeLog LICENSE NOTES README TODO announce
76
77 %{perl_vendorarch}/Astro/FITS
78 %dir %{perl_vendorarch}/auto/Astro/FITS
79 %dir %{perl_vendorarch}/auto/Astro/FITS/CFITSIO
80 %{perl_vendorarch}/auto/Astro/FITS/CFITSIO/CFITSIO.bs
81 %{perl_vendorarch}/auto/Astro/FITS/CFITSIO/autosplit.ix
82 %attr(755,root,root) %{perl_vendorarch}/auto/Astro/FITS/CFITSIO/CFITSIO.so
83 %{_mandir}/man3/*
84 %dir %{_examplesdir}/%{name}-%{version}
85 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
86 %{_examplesdir}/%{name}-%{version}/INDEX
87 %{_examplesdir}/%{name}-%{version}/*.fits.*
This page took 0.103065 seconds and 2 git commands to generate.