]> git.pld-linux.org Git - packages/perl-Array-RefElem.git/blob - perl-Array-RefElem.spec
- add CC to %{__make}
[packages/perl-Array-RefElem.git] / perl-Array-RefElem.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Array
7 %define pnam    RefElem
8 Summary:        Array::RefElem - set up array elements as aliases
9 Summary(pl.UTF-8):      Array::RefElem - ustawianie elementów tablicy jako aliasów
10 Name:           perl-Array-RefElem
11 Version:        1.00
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/G/GA/GAAS/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  43ff2dd2049258634cb00697198572d1
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module gives direct access to some of the internal Perl routines
24 that let you store things in arrays and hashes.
25
26 %description -l pl.UTF-8
27 Ten moduł daje bezpośredni dostęp do niektórych wewnętrznych funkcji
28 Perla pozwalających zapisywać różne rzeczy w tablicach i haszach.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make} \
37         CC="%{__cc}" \
38         OPTIMIZE="%{rpmcflags}"
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %dir %{perl_vendorarch}/Array
55 %{perl_vendorarch}/Array/*.pm
56 %dir %{perl_vendorarch}/auto/Array
57 %dir %{perl_vendorarch}/auto/Array/RefElem
58 %{perl_vendorarch}/auto/Array/RefElem/*.bs
59 %attr(755,root,root) %{perl_vendorarch}/auto/Array/RefElem/*.so
60 %{_mandir}/man3/*
This page took 0.127466 seconds and 4 git commands to generate.