]> git.pld-linux.org Git - packages/perl-App-SVN-Bisect.git/blob - perl-App-SVN-Bisect.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-App-SVN-Bisect.git] / perl-App-SVN-Bisect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    App
6 %define pnam    SVN-Bisect
7 Summary:        App::SVN::Bisect - binary search through svn revisions
8 Name:           perl-App-SVN-Bisect
9 Version:        1.1
10 Release:        1
11 License:        artistic_2
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/authors/id/I/IN/INFINOID/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  a929a878b7bee04adae2e592770c0ea2
15 Patch0:         %{name}-locale.patch
16 URL:            http://search.cpan.org/dist/App-SVN-Bisect/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(IO::All) > 0.38
21 BuildRequires:  perl-Test-Exception
22 BuildRequires:  perl-Test-Output
23 BuildRequires:  perl-Test-Pod
24 BuildRequires:  perl-Test-Pod-Coverage
25 BuildRequires:  perl-YAML-Syck
26 BuildRequires:  subversion
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module implements the backend of the "svn-bisect" command line
33 tool. See the POD documentation of that tool, for usage details.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37 %patch0 -p1
38
39 %build
40 %{__perl} Build.PL \
41         destdir=$RPM_BUILD_ROOT \
42         installdirs=vendor
43
44 ./Build
45
46 %{?with_tests:./Build test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 ./Build install
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README TODO
59 %attr(755,root,root) %{_bindir}/svn-bisect
60 %dir %{perl_vendorlib}/App/SVN
61 %{perl_vendorlib}/App/SVN/*.pm
62 %{_mandir}/man3/*
63 %{_mandir}/man1/*
This page took 0.083028 seconds and 4 git commands to generate.