]> git.pld-linux.org Git - packages/perl-App-SVN-Bisect.git/blob - perl-App-SVN-Bisect.spec
4bd8f981b92f65db70055f1c5e6002422f140415
[packages/perl-App-SVN-Bisect.git] / perl-App-SVN-Bisect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    App
7 %define pnam    SVN-Bisect
8 Summary:        App::SVN::Bisect - binary search through svn revisions
9 Name:           perl-App-SVN-Bisect
10 Version:        1.0
11 Release:        1
12 License:        artistic_2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/authors/id/I/IN/INFINOID/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d8540f354b27d904eee56cc473542cbc
16 Patch0:         %{name}-locale.patch
17 URL:            http://search.cpan.org/dist/App-SVN-Bisect/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(IO::All) > 0.38
22 BuildRequires:  perl-Test-Exception
23 BuildRequires:  perl-Test-Output
24 BuildRequires:  perl-Test-Pod
25 BuildRequires:  perl-Test-Pod-Coverage
26 BuildRequires:  perl-YAML-Syck
27 BuildRequires:  subversion
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module implements the backend of the "svn-bisect" command line
34 tool. See the POD documentation of that tool, for usage details.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %patch0 -p1
39
40 %build
41 %{__perl} Build.PL \
42         destdir=$RPM_BUILD_ROOT \
43         installdirs=vendor
44
45 ./Build
46
47 %{?with_tests:./Build test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 ./Build install
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README TODO
60 %attr(755,root,root) %{_bindir}/svn-bisect
61 %dir %{perl_vendorlib}/App/SVN
62 %{perl_vendorlib}/App/SVN/*.pm
63 %{_mandir}/man3/*
64 %{_mandir}/man1/*
This page took 0.057507 seconds and 3 git commands to generate.