]> git.pld-linux.org Git - SPECS.git/blob - perl-Algorithm-Diff.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-Algorithm-Diff.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %define         pdir    Algorithm
6 %define         pnam    Diff
7 Summary:        Algorithm::Diff - compute `intelligent' differences between two files / lists
8 Summary(pl.UTF-8):      Algorithm::Diff - ,,inteligentne'' znajdowanie różnic pomiędzy dwoma plikami / listami
9 Name:           perl-Algorithm-Diff
10 # need additional '0' to update from 1.1903
11 %define pver    1.201
12 Version:        %{pver}0
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Algorithm/%{pdir}-%{pnam}-%{pver}.tar.gz
18 # Source0-md5:  2eaae910f5220261ee2bbdfc4a8df2c2
19 URL:            https://metacpan.org/release/Algorithm-Diff
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Algorithm::Diff finds differences between two files, two strings, or
28 any other two lists of things. It uses an intelligent algorithm
29 similar to (or identical to) the one used by the Unix `diff' program. 
30 It is guaranteed to find the *smallest possible* set of differences.
31
32 %description -l pl.UTF-8
33 Algorithm::Diff wyszukuje różnice pomiędzy dwoma plikami, łańcuchami
34 lub dwiema innymi listami. korzysta on z inteligentnego algorytmu
35 podobnego do (lub identycznego) używanego przez uniksowy program
36 ,,diff''. Zagwarantowane jest znalezienie *najmniejszego możliwego*
37 zbioru różnic.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{pver}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 cp -p bin/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/Algorithm/Diff.pm
65 %{perl_vendorlib}/Algorithm/DiffOld.pm
66 %{_mandir}/man3/Algorithm::Diff.3pm*
67 %{_mandir}/man3/Algorithm::DiffOld.3pm*
68 %{_examplesdir}/%{name}-%{version}
This page took 0.255152 seconds and 3 git commands to generate.