]> git.pld-linux.org Git - SPECS.git/blob - perl-Algorithm-Dependency.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Algorithm-Dependency.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %define         pdir    Algorithm
6 %define         pnam    Dependency
7 Summary:        Algorithm::Dependency - Base class for implementing various dependency trees
8 Summary(pl.UTF-8):      Algorithm::Dependency - podstawowa klasa do tworzenia różnych drzew zależności
9 Name:           perl-Algorithm-Dependency
10 Version:        1.112
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Algorithm/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d848624b0c483adf7f7f60f6ae2edc8f
17 URL:            https://metacpan.org/release/Algorithm-Dependency
18 %if %{with tests}
19 BuildRequires:  perl(File::Spec) >= 0.80
20 BuildRequires:  perl-Params-Util >= 0.31
21 BuildRequires:  perl-Scalar-List-Utils >= 1.11
22 BuildRequires:  perl-Test-ClassAPI >= 0.6
23 BuildRequires:  perl-Test-Simple >= 0.47
24 %endif
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRequires:  rpmbuild(macros) >= 1.745
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Base class for implementing various dependency trees.
33
34 %description -l pl.UTF-8
35 Podstawowa klasa do tworzenia różnych drzew zależności.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %{perl_vendorlib}/Algorithm/*.pm
59 %{perl_vendorlib}/Algorithm/Dependency
60 %{_mandir}/man3/*
This page took 0.114923 seconds and 3 git commands to generate.