]> git.pld-linux.org Git - packages/perl-Acme-Damn.git/blob - perl-Acme-Damn.spec
- converted to UTF-8
[packages/perl-Acme-Damn.git] / perl-Acme-Damn.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Acme
7 %define pnam    Damn
8 Summary:        Acme::Damn - 'Unbless' Perl objects
9 Summary(pl.UTF-8):   Acme::Damn - "odbłogosławianie" obiektów Perla
10 Name:           perl-Acme-Damn
11 Version:        0.03
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  02a3c8b947d3f2888bc2455f7405f7c1
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Acme::Damn provides a single routine, damn(), which takes a blessed
24 reference (a Perl object), and unblesses it, to return the original
25 reference. I can't think of any reason why you might want to do this,
26 but just because it's of no use doesn't mean that you shouldn't be
27 able to do it.
28
29 %description -l pl.UTF-8
30 Acme::Damn dostarcza jedną funkcję: damn(), która przyjmuje
31 pobłogosławioną referencję (obiekt perlowy) i odbłogosławia ją, aby
32 zwrócić oryginalną referencję. Nie znaleziono na razie powodu, żeby
33 to robić, ale to, że takie działanie nie ma zastosowania, nie znaczy,
34 że nie powinno dać się tego zrobić.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/Acme/*.pm
60 %dir %{perl_vendorarch}/auto/Acme/Damn
61 %{perl_vendorarch}/auto/Acme/Damn/*.bs
62 %attr(755,root,root) %{perl_vendorarch}/auto/Acme/Damn/*.so
63 %{_mandir}/man3/*
This page took 0.075343 seconds and 3 git commands to generate.