]> git.pld-linux.org Git - SPECS.git/blob - perl-Acme-Cow.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Acme-Cow.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %define         _pacver 0.1
6 %define         pdir    Acme
7 %define         pnam    Cow
8 Summary:        Acme::Cow Perl module - talking cow
9 Summary(pl.UTF-8):      Moduł Perla Acme::Cow - gadająca krowa
10 Name:           perl-Acme-Cow
11 Version:        %{_pacver}
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.nog.net/~tony/warez/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f798f990d5e13c91d5cd85cc4e05d3b7
18 Source1:        cowsay.sysconfig
19 Source2:        cowsay.sh
20 Source3:        cowsay.csh
21 Patch0:         cowsay-PLD.patch
22 Patch1:         cowsay-random.patch
23 URL:            http://www.nog.net/~tony/warez/cowsay.shtml
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  perl-Text-Template
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Acme::Cow is the logical evolution of the old cowsay program. Cows are
32 derived from a base class (Acme::Cow) or from external files.
33
34 Cows can be made to say or think many things, optionally filling and
35 justifying their text out to a given margin.
36
37 %description -l pl.UTF-8
38 Acme::Cow wyewoluował logicznie ze starego programu cowsay. Krowy
39 pochodzą z klasy bazowej (Acme::Cow) lub z plików zewnętrznych.
40
41 Krowy mogą mówić i myśleć o wielu rzeczach, opcjonalnie dopełniając i
42 wyrównując swój tekst do zadanego marginesu.
43
44 %package -n cowsay
45 Summary:        A Configurable Speaking/Thinking Cow
46 Summary(pl.UTF-8):      Konfigurowalna mówiąco-myśląca krowa
47 Version:        4.00
48 Group:          Applications/Games
49 Suggests:       perldoc
50
51 %description -n cowsay
52 cowsay is basically a text filter. Send some text into it, and you get
53 a cow saying your text. Very easy to use.
54
55 %description -n cowsay -l pl.UTF-8
56 cowsay to prosty filtr tekstowy. Podaje mu się trochę tekstu, a on
57 wyświetla krowę mówiącą ten tekst. Bardzo proste w użyciu.
58
59 %package -n cowsay-on-login
60 Summary:        Displays cow on login
61 Summary(pl.UTF-8):      Pokazywanie się krowy przy logowaniu
62 Version:        4.00
63 Group:          Applications/Games
64 Requires:       cowsay
65 Obsoletes:      cowsay-on-login-static
66
67 %description -n cowsay-on-login
68 If you want a cow to be displayed each time when you log on this
69 package is what you need.
70
71 %description -n cowsay-on-login -l pl.UTF-8
72 Gdy się chce, żeby krowa pokazywała się przy każdym logowaniu ten
73 pakiet jest tym, czego potrzeba.
74
75 %prep
76 %setup -q -n %{pdir}-%{pnam}-%{_pacver}
77 %patch0 -p1
78 %patch1 -p1
79
80 %build
81 %{__perl} Makefile.PL \
82         INSTALLDIRS=vendor
83 %{__make}
84
85 %{?with_tests:%{__make} test}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %{__make} install-cows \
94         PREFIX=$RPM_BUILD_ROOT%{_prefix}
95
96 rm -f $RPM_BUILD_ROOT%{_bindir}/cowthink
97 ln -s %{_bindir}/cowsay $RPM_BUILD_ROOT%{_bindir}/cowthink
98
99 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{profile.d,sysconfig}
100 install %{SOURCE1}      $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/cowsay
101 install %{SOURCE2}      $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102 install %{SOURCE3}      $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc Changes README
110 # use macros:
111 #%{perl_vendorlib}/Acme/Cow.pm
112 %{perl_vendorlib}/Acme
113 #%%{perl_vendorarch}/...
114 %attr(755,root,root) %{_bindir}/cowpm
115 %{_mandir}/man3/*
116 %{_mandir}/man1/cowpm.1p*
117 %{_datadir}/cows
118
119 %files -n cowsay
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/cowsay
122 %attr(755,root,root) %{_bindir}/cowthink
123 %{_mandir}/man1/cowsay*
124 %{_mandir}/man1/cowthink*
125
126 %files -n cowsay-on-login
127 %defattr(644,root,root,755)
128 %attr(755,root,root) /etc/profile.d/cowsay.*sh
129 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cowsay
This page took 0.605963 seconds and 3 git commands to generate.