]> git.pld-linux.org Git - SPECS.git/blob - perl-AcePerl.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-AcePerl.spec
1 %define pdir    Ace
2 Summary:        AcePerl - Perl interface for the ACEDB object-oriented database
3 Summary(pl.UTF-8):      AcePerl - interfejs perlowy do obiektowej bazy danych ACEDB
4 Name:           perl-AcePerl
5 Version:        1.92
6 Release:        15
7 # same as perl
8 License:        GPL v1+ or Artistic
9 Group:          Development/Languages/Perl
10 Source0:        http://www.cpan.org/modules/by-module/Ace/AcePerl-%{version}.tar.gz
11 # Source0-md5:  485e54655a15d8dc5c471fed07092414
12 Patch0:         %{name}-defaults.patch
13 Patch1:         %{name}-path.patch
14 URL:            http://search.cpan.org/dist/AcePerl/
15 BuildRequires:  cpp
16 BuildRequires:  libtirpc-devel
17 BuildRequires:  perl-Digest-MD5
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  rpcsvc-proto
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       perl-GD
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         tirpccflags     %(pkg-config --cflags libtirpc)
26
27 %description
28 AcePerl provides an interface to the ACEDB object-oriented database.
29 Designed specifically for use in genome sequencing projects, ACEDB
30 provides powerful modeling and management services for biological and
31 laboratory data. For others, it is a good open source introduction to
32 the world of object-oriented databases.
33
34 %description -l pl.UTF-8
35 AcePerl umożliwia dostęp do obiektowej bazy danych ACEDB. Został
36 zaprojektowany dla projektów dotyczących genomów. ACEDB udostępnia
37 potężne usługi modelowania i zarządzania danymi biologicznymi i
38 laboratoryjnymi. Ponadto, jest on dobrym wprowadzeniem otwartego
39 oprogramowania w swiat baz obiektowych.
40
41 %package -n perl-AceBrowser
42 Summary:        AceBrowser - collection of CGI scripts providing interface to ACEDB
43 Summary(pl.UTF-8):      AceBrowser - zbiór skryptów CGI stanowiących interfejs do ACEDB
44 Group:          Development/Languages/Perl
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       webserver = apache
47
48 %description -n perl-AceBrowser
49 AceBrowser is a collection of CGI scripts that run on top of AcePerl
50 to provide a simple browsable interface to ACEDB databases. Some of
51 the code has been tuned for the C. elegans database, but most of it is
52 fully generic.
53
54 %description -n perl-AceBrowser -l pl.UTF-8
55 AceBrowser jest zbiorem skryptów CGI, działających w oparciu o AcePerl
56 i stanowiących prosty interfejs do baz danych ACEDB. Część kodu
57 zoptymalizowano dla bazy danych C. elegans, lecz większość jest
58 ogólna.
59
60 %prep
61 %setup -q -n AcePerl-%{version}
62 %patch0 -p1
63 %patch1 -p1
64
65 %build
66 # Makefile.PL does not read from non-terminal stdin
67 %{__perl} Makefile.PL < /dev/null \
68         INSTALLDIRS=vendor
69 %{__make} \
70         OPTIMIZE="%{rpmcflags}" \
71         COMPILER="%{__cc} -DACEDB4 %{rpmcflags} -fPIC"
72 cd RPC
73 %{__perl} Makefile.PL \
74         INSTALLDIRS=vendor
75 # prevent race conditions in parallel build
76 %{__make} -C ../acelib rpcace.h
77 %{__make} \
78         OPTIMIZE="%{rpmcflags}" \
79         COMPILER="%{__cc} -DACEDB4 %{rpmcflags} -fPIC %{tirpccflags}"
80 cd ../Freesubs
81 %{__perl} Makefile.PL \
82         INSTALLDIRS=vendor
83 %{__make} \
84         OPTIMIZE="%{rpmcflags}" \
85         COMPILER="%{__cc} -DACEDB4 %{rpmcflags} -fPIC"
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93 cd RPC
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96 cd ../Freesubs
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99 cd ..
100
101 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
102 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd,/home/services/httpd/{cgi-bin,html}}/ace
103 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
104 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Ace/.packlist
105 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Ace/Freesubs/.packlist
106 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Ace/RPC/.packlist
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc ChangeLog README DISCLAIMER.txt
114 %attr(755,root,root) %{_bindir}/ace.pl
115 %{perl_vendorlib}/Ace.pm
116 %dir %{perl_vendorlib}/Ace
117 %{perl_vendorlib}/Ace/[!B]*
118 %{perl_vendorlib}/GFF
119 %{perl_vendorlib}/auto/Ace
120 %dir %{perl_vendorarch}/Ace
121 %{perl_vendorarch}/Ace/*.pm
122 %dir %{perl_vendorarch}/auto/Ace
123 %dir %{perl_vendorarch}/auto/Ace/Freesubs
124 %attr(755,root,root) %{perl_vendorarch}/auto/Ace/Freesubs/Freesubs.so
125 %dir %{perl_vendorarch}/auto/Ace/RPC
126 %attr(755,root,root) %{perl_vendorarch}/auto/Ace/RPC/RPC.so
127 %{_examplesdir}/%{name}-%{version}
128 %{_mandir}/man1/ace.pl*
129 %{_mandir}/man3/Ace.3pm*
130 %{_mandir}/man3/Ace::[!B]*
131
132 %files -n perl-AceBrowser
133 %defattr(644,root,root,755)
134 %doc README.ACEBROWSER
135 %dir %{_sysconfdir}/httpd/ace
136 %dir /home/services/httpd/cgi-bin/ace
137 %dir /home/services/httpd/html/ace
138 %{perl_vendorlib}/Ace/Browser
139 %{_mandir}/man3/Ace::B*
This page took 0.402534 seconds and 3 git commands to generate.