]> git.pld-linux.org Git - SPECS.git/blob - perl-AI-NeuralNet-Mesh.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / perl-AI-NeuralNet-Mesh.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4
5 %define         pdir    AI
6 %define         pnam    NeuralNet-Mesh
7 Summary:        AI::NeuralNet::Mesh - an optimized, accurate neural network Mesh
8 Summary(pl.UTF-8):      AI::NeuralNet::Mesh - zoptymalizowana, dokładna sieć neuronowa Mesh
9 Name:           perl-AI-NeuralNet-Mesh
10 Version:        0.44
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.zip
16 # Source0-md5:  5d1c68c7d494da158ce50c263a7d77a1
17 URL:            http://search.cpan.org/dist/AI-NeuralNet-Mesh/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  unzip
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 AI::NeuralNet::Mesh is an optimized, accurate neural network Mesh. It
26 was designed with accuracy and speed in mind.
27
28 This network model is very flexible. It will allow for classic binary
29 operation or any range of integer or floating-point inputs you care to
30 provide. With this you can change activation types on a per node or
31 per layer basis (you can even include your own anonymous subs as
32 activation types). You can add sigmoid transfer functions and control
33 the threshold. You can learn data sets in batch, and load CSV data set
34 files. You can do almost anything you need to with this module. This
35 code is designed to be flexible.
36
37 %description -l pl.UTF-8
38 AI::NeuralNet::Mesh to zoptymalizowana, dokładna sieć neuronowa Mesh.
39 Została zaprojektowana z myślą o dokładności i szybkości.
40
41 Model sieci jest bardzo elastyczny. Pozwala na klasyczne operacje
42 binarne oraz dowolny zakres wejść całkowitych lub zmiennoprzecinkowych
43 jaki tylko chcemy dostarczyć. Można zmienić czasy aktywacji dla węzłów
44 lub warstw (można nawet dołączyć własne anonimowe podsieci jako typy
45 aktywacji). Można dodawać funkcje transferu sigmoidalnego i kontrolę
46 progu. Można uczyć zbiorów danych wsadowo i wczytywać dane z plików
47 CSV. Można robić prawie wszystko co jest potrzebne. Kod jest
48 zaprojektowany tak, by był elastyczny.
49
50 %prep
51 %setup -q -c
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes *.htm README
75 %{perl_vendorlib}/AI/NeuralNet/*.pm
76 %dir %{_examplesdir}/%{name}-%{version}
77 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
78 %{_examplesdir}/%{name}-%{version}/*.mesh
79 %{_examplesdir}/%{name}-%{version}/*.txt
80 %{_examplesdir}/%{name}-%{version}/*.dat
81 %{_examplesdir}/%{name}-%{version}/*.pcx
82 %{_mandir}/man3/*
This page took 0.736136 seconds and 3 git commands to generate.