]> git.pld-linux.org Git - packages/pcsc-driver-ccid.git/blob - pcsc-driver-ccid.spec
- checked skip_post_check_so; there is no fix, it must stay this way
[packages/pcsc-driver-ccid.git] / pcsc-driver-ccid.spec
1 Summary:        Generic USB CCID (Chip/Smart Card Interface Devices) driver
2 Summary(pl.UTF-8):      Ogólny sterownik USB CCID (Chip/Smart Card Interface Devices)
3 Name:           pcsc-driver-ccid
4 Version:        1.4.0
5 Release:        4
6 License:        LGPL v2.1+
7 Group:          Libraries
8 #Source0Download: http://alioth.debian.org/project/showfiles.php?group_id=30105
9 Source0:        http://alioth.debian.org/frs/download.php/3333/ccid-%{version}.tar.bz2
10 # Source0-md5:  745d681bed2e17579fa6144e19bcb01d
11 URL:            http://pcsclite.alioth.debian.org/ccid.html
12 BuildRequires:  libusb-devel >= 1.0
13 BuildRequires:  pcsc-lite-devel >= 1.6.2
14 BuildRequires:  perl-base
15 BuildRequires:  pkgconfig
16 BuildRequires:  rpmbuild(macros) >= 1.583
17 Requires:       pcsc-lite >= 1.6.2
18 Provides:       ccid = %{version}-%{release}
19 Obsoletes:      ccid < 1.4.0-3
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         usbdropdir      /usr/%{_lib}/pcsc/drivers
23 %define         ccidtwindir     /usr/%{_lib}/pcsc/drivers
24
25 # pcscd provides log_msg and log_xxd functions
26 %define         skip_post_check_so      libccid.so.1.4.0 libccidtwin.so.1.4.0
27
28 %description
29 This package provides generic USB CCID (Chip/Smart Card Interface
30 Devices) driver.
31
32 Full lists of supported devices are available here:
33 <http://pcsclite.alioth.debian.org/supported.html>
34 <http://pcsclite.alioth.debian.org/shouldwork.html>
35
36 %description -l pl.UTF-8
37 Ten pakiet zawiera ogólny sterownik USB CCID (Chip/Smart Card
38 Interface Devices).
39
40 Pełne listy obsługiwanych urządzeń są dostępne na WWW:
41 <http://pcsclite.alioth.debian.org/supported.html>
42 <http://pcsclite.alioth.debian.org/shouldwork.html>
43
44 %package -n udev-pcsc-driver-ccid
45 Summary:        udev support for CCID PC/SC driver
46 Summary(pl.UTF-8):      Obsługa udev dla sterownika PC/SC CCID
47 Group:          Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       udev-core
50
51 %description -n udev-pcsc-driver-ccid
52 udev support for CCID PC/SC driver.
53
54 %description -n udev-pcsc-driver-ccid -l pl.UTF-8
55 Obsługa udev dla sterownika PC/SC CCID.
56
57 %package serial
58 Summary:        Generic USB CCID driver for readers connected to serial port
59 Summary(pl.UTF-8):      Ogólny sterownik USB CCID dla czytników podłączonych przez port szeregowy
60 Group:          Libraries
61 Requires:       pcsc-lite >= 1.6.2
62
63 %description serial
64 Generic USB CCID driver for readers connected to serial port.
65 Supported CCID devices:
66 - Gemplus/Gemalto GemPC Twin
67 - Gemplus/Gemalto GemCore POS Pro
68 - Gemplus/Gemalto GemCore SIM Pro
69 - Gemalto GemPC PinPad
70
71 %description serial -l pl.UTF-8
72 Ogólny sterownik USB CCID dla czytników podłączonych przez port
73 szeregowy. Obsługiwane urządzenia CCID:
74 - Gemplus/Gemalto GemPC Twin
75 - Gemplus/Gemalto GemCore POS Pro
76 - Gemplus/Gemalto GemCore SIM Pro
77 - Gemalto GemPC PinPad
78
79 %prep
80 %setup -q -n ccid-%{version}
81
82 %build
83 %configure \
84         --enable-ccidtwindir=%{ccidtwindir} \
85         --enable-twinserial \
86         --enable-usbdropdir=%{usbdropdir} \
87         --enable-udev
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT/lib/udev/rules.d
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %{__make} -C src install_ccidtwin \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 cp -p src/pcscd_ccid.rules $RPM_BUILD_ROOT/lib/udev/rules.d/70-pcscd_ccid.rules
101
102 rm $RPM_BUILD_ROOT%{_docdir}/ccid/README_Kobil_mIDentity_switch.txt
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS ChangeLog README SCARDGETATTRIB.txt readers/supported_readers.txt contrib/Kobil_mIDentity_switch/README_Kobil_mIDentity_switch.txt
110 %attr(755,root,root) %{_bindir}/RSA_SecurID_getpasswd
111 %attr(755,root,root) %{_sbindir}/Kobil_mIDentity_switch
112 %dir %{usbdropdir}/ifd-ccid.bundle
113 %dir %{usbdropdir}/ifd-ccid.bundle/Contents
114 %{usbdropdir}/ifd-ccid.bundle/Contents/Info.plist
115 %dir %{usbdropdir}/ifd-ccid.bundle/Contents/Linux
116 %attr(755,root,root) %{usbdropdir}/ifd-ccid.bundle/Contents/Linux/libccid.so*
117 %{_mandir}/man1/RSA_SecurID_getpasswd.1*
118 %{_mandir}/man8/Kobil_mIDentity_switch.8*
119
120 %files -n udev-pcsc-driver-ccid
121 %defattr(644,root,root,755)
122 /lib/udev/rules.d/70-pcscd_ccid.rules
123
124 %files serial
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README SCARDGETATTRIB.txt readers/supported_readers.txt
127 %config(noreplace) %verify(not md5 mtime size) /etc/reader.conf.d/libccidtwin
128 %attr(755,root,root) %{ccidtwindir}/libccidtwin.so*
This page took 0.03769 seconds and 3 git commands to generate.