]> git.pld-linux.org Git - packages/pcre.git/blob - pcre.spec
- up to 7.7
[packages/pcre.git] / pcre.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  tests           # don't perform "make check"
5 #
6 Summary:        Perl-Compatible Regular Expression library
7 Summary(pl.UTF-8):      Biblioteka perlowych wyrażeń regularnych
8 Summary(pt_BR.UTF-8):   Biblioteca de expressões regulares versão
9 Name:           pcre
10 Version:        7.7
11 Release:        1
12 License:        BSD (see LICENCE)
13 Group:          Libraries
14 Source0:        ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
15 # Source0-md5:  4b2e9cde1f7227448dddba59843efa0b
16 Patch0:         %{name}-pcreposix-glibc-conflict.patch
17 URL:            http://www.pcre.org/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake
20 BuildRequires:  bzip2-devel     
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  readline-devel  
24 BuildRequires:  zlib-devel      
25 Obsoletes:      libpcre0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 PCRE stands for the Perl Compatible Regular Expression library. It
30 contains routines to match text against regular expressions similar to
31 Perl's. It also contains a POSIX compatibility library.
32
33 %description -l es.UTF-8
34 A biblioteca PCRE é um set de funções que implementam expressões
35 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
36 sua própria API nativa, bem como um set de funções wrapper para
37 corresponder ao padrão POSIX de expressões regulares.
38
39 %description -l pl.UTF-8
40 PCRE (Perl-Compatible Regular Expression) oznacza bibliotekę wyrażeń
41 regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowujące
42 tekst do wyrażeń regularnych podobnych do tych znanych z Perla.
43 Zawiera także bibliotekę kompatybilną z POSIX.
44
45 %description -l pt_BR.UTF-8
46 A biblioteca PCRE é um conjunto de funções que implementam expressões
47 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
48 sua própria API nativa, bem como um conjuntos de funções wrapper para
49 corresponder ao padrão POSIX de expressões regulares.
50
51 %package devel
52 Summary:        Perl-Compatible Regular Expression header files and development documentation
53 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek pcre
54 Summary(pt_BR.UTF-8):   Arquivos para desenvolvimento com pcre
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Obsoletes:      libpcre0-devel
58
59 %description devel
60 Perl-Compatible Regular Expression header files and development
61 documentation.
62
63 %description devel -l es.UTF-8
64 A biblioteca PCRE é um set de funções que implementam expressões
65 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
66 sua própria API nativa, bem como um set de funções wrapper para
67 corresponder ao padrão POSIX de expressões regulares.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe i dokumentacja do bibliotek pcre.
71
72 %description devel -l pt_BR.UTF-8
73 A biblioteca PCRE é um conjunto de funções que implementam expressões
74 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
75 sua própria API nativa, bem como um conjunto de funções wrapper para
76 corresponder ao padrão POSIX de expressões regulares.
77
78 %package static
79 Summary:        Perl-Compatible Regular Expression static libraries
80 Summary(pl.UTF-8):      Biblioteki statyczne pcre
81 Summary(pt_BR.UTF-8):   Arquivos para desenvolvimento estático com pcre
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Perl-Compatible Regular Expression library static libraries.
87
88 %description static -l es.UTF-8
89 A biblioteca PCRE é um set de funções que implementam expressões
90 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
91 sua própria API nativa, bem como um set de funções wrapper para
92 corresponder ao padrão POSIX de expressões regulares.
93
94 %description static -l pl.UTF-8
95 Biblioteki statyczne pcre.
96
97 %description static -l pt_BR.UTF-8
98 A biblioteca PCRE é um conjunto de funções que implementam expressões
99 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
100 sua própria API nativa, bem como um conjunto de funções wrapper para
101 corresponder ao padrão POSIX de expressões regulares.
102
103 %package cxx
104 Summary:        C++ wrapper to PCRE library
105 Summary(pl.UTF-8):      Interfejs C++ do biblioteki PCRE
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108
109 %description cxx
110 C++ wrapper to PCRE library.
111
112 %description cxx -l pl.UTF-8
113 Interfejs C++ do biblioteki PCRE.
114
115 %package cxx-devel
116 Summary:        Header file for C++ wrapper to PCRE library
117 Summary(pl.UTF-8):      Plik nagłówkowy interfejsu C++ do biblioteki PCRE
118 Group:          Development/Libraries
119 Requires:       %{name}-cxx = %{version}-%{release}
120 Requires:       %{name}-devel = %{version}-%{release}
121 Requires:       libstdc++-devel
122
123 %description cxx-devel
124 Header file for C++ wrapper to PCRE library.
125
126 %description cxx-devel -l pl.UTF-8
127 Plik nagłówkowy interfejsu C++ do biblioteki PCRE.
128
129 %package cxx-static
130 Summary:        Static version of pcrecpp library
131 Summary(pl.UTF-8):      Statyczna wersja biblioteki pcrecpp
132 Group:          Development/Libraries
133 Requires:       %{name}-cxx-devel = %{version}-%{release}
134
135 %description cxx-static
136 Static version of pcrecpp library.
137
138 %description cxx-static -l pl.UTF-8
139 Statyczna wersja biblioteki pcrecpp.
140
141 %package -n pcregrep
142 Summary:        Grep using Perl Compatible Regular Expressions
143 Summary(pl.UTF-8):      Grep używający perlowych wyrażeń regularnych
144 Group:          Applications/Text
145 Obsoletes:      pgrep
146
147 %description -n pcregrep
148 pgrep is a grep workalike which uses perl-style regular expressions
149 instead of POSIX regular expressions.
150
151 %description -n pcregrep -l pl.UTF-8
152 pgrep jest programem działającym podobnie do grepa, ale używających
153 perlowych wyrażeń regularnych, a nie posiksowych.
154
155 %package -n pcretest
156 Summary:        A program for testing Perl-comaptible regular expressions
157 Summary(pl.UTF-8):      Program do testowania kompatybilnych z perlem wyrażeń regualarnych
158 Group:          Applications/Text
159
160 %description -n pcretest
161 pcretest is a program which you can use to test regular expression
162
163 %description -n pcretest -l pl.UTF-8
164 pcretest jest programem za pomocą można sprawdzić poprawność wyrażenia regularnego
165
166 %package doc-html
167 Summary:        Documentation for PCRE in HTML format
168 Summary(pl.UTF-8):      Dokumentacja dla PCRE w formacie HTML
169 Group:          Applications/Text
170
171 %description doc-html
172 Documentation for PCRE in HTML format.
173
174 %description doc-html -l pl.UTF-8
175 Dokumentacja dla PCRE w formacie HTML.
176
177 %prep
178 %setup -q
179 %patch0 -p1
180
181 %build
182 %{__libtoolize}
183 %{__aclocal}
184 %{__autoconf}
185 %{__autoheader}
186 %{__automake}
187 %configure \
188         CXXLDFLAGS="%{rpmldflags}" \
189         %{!?with_static_libs:--enable-static=no} \
190         --enable-utf8 \
191         --enable-unicode-properties \
192         --enable-pcregrep-libz \
193         --enable-pcregrep-libbz2 \
194         --enable-pcretest-libreadline
195
196 %{__make}
197
198 %if %{with tests}
199 %{__make} check
200 %endif
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204 install -d $RPM_BUILD_ROOT{/%{_lib},%{_examplesdir}/%{name}-%{version}}
205
206 %{__make} install \
207         DESTDIR=$RPM_BUILD_ROOT
208
209 mv -f $RPM_BUILD_ROOT%{_libdir}/libpcre.so.* $RPM_BUILD_ROOT/%{_lib}
210 mv -f $RPM_BUILD_ROOT%{_libdir}/libpcreposix.so.* $RPM_BUILD_ROOT/%{_lib}
211
212 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libpcre.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpcre.so
213 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libpcreposix.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpcreposix.so
214
215 install pcredemo.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
216
217 rm -rf $RPM_BUILD_ROOT%{_docdir}/pcre
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %post   -p /sbin/ldconfig
223 %postun -p /sbin/ldconfig
224
225 %post   cxx -p /sbin/ldconfig
226 %postun cxx -p /sbin/ldconfig
227
228 %files
229 %defattr(644,root,root,755)
230 %doc README NEWS LICENCE ChangeLog
231 %attr(755,root,root) /%{_lib}/libpcre.so.*.*.*
232 %attr(755,root,root) %ghost /%{_lib}/libpcre.so.0
233 %attr(755,root,root) /%{_lib}/libpcreposix.so.*.*.*
234 %attr(755,root,root) %ghost /%{_lib}/libpcreposix.so.0
235
236 %files devel
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_bindir}/pcre-config
239 %attr(755,root,root) %{_libdir}/libpcre.so
240 %attr(755,root,root) %{_libdir}/libpcreposix.so
241 %{_libdir}/libpcre.la
242 %{_libdir}/libpcreposix.la
243 %{_includedir}/pcre.h
244 %{_includedir}/pcreposix.h
245 %{_pkgconfigdir}/libpcre.pc
246 %{_mandir}/man1/pcre-config.1*
247 %{_mandir}/man3/pcre*.3*
248 %exclude %{_mandir}/man3/pcrecpp.3*
249 %{_examplesdir}/%{name}-%{version}
250
251 %if %{with static_libs}
252 %files static
253 %defattr(644,root,root,755)
254 %{_libdir}/libpcre.a
255 %{_libdir}/libpcreposix.a
256 %endif
257
258 %files cxx
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_libdir}/libpcrecpp.so.*.*.*
261 %attr(755,root,root) %ghost %{_libdir}/libpcrecpp.so.0
262
263 %files cxx-devel
264 %defattr(644,root,root,755)
265 %attr(755,root,root) %{_libdir}/libpcrecpp.so
266 %{_libdir}/libpcrecpp.la
267 %{_includedir}/pcrecpp.h
268 %{_includedir}/pcre_scanner.h
269 %{_includedir}/pcre_stringpiece.h
270 %{_includedir}/pcrecpparg.h
271 %{_pkgconfigdir}/libpcrecpp.pc
272 %{_mandir}/man3/pcrecpp.3*
273
274 %if %{with static_libs}
275 %files cxx-static
276 %defattr(644,root,root,755)
277 %{_libdir}/libpcrecpp.a
278 %endif
279
280 %files -n pcregrep
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_bindir}/pcregrep
283 %{_mandir}/man1/pcregrep.1*
284
285 %files -n pcretest
286 %defattr(644,root,root,755)
287 %attr(755,root,root) %{_bindir}/pcretest
288 %{_mandir}/man1/pcretest.1*
289
290 %files doc-html
291 %defattr(644,root,root,755)
292 %doc doc/html/*
This page took 0.078174 seconds and 4 git commands to generate.