]> git.pld-linux.org Git - packages/pcre.git/blob - pcre.spec
- release 2
[packages/pcre.git] / pcre.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  tests           # don't perform "make check"
5 #
6 Summary:        Perl-Compatible Regular Expression library
7 Summary(pl.UTF-8):      Biblioteka perlowych wyrażeń regularnych
8 Summary(pt_BR.UTF-8):   Biblioteca de expressões regulares versão
9 Name:           pcre
10 Version:        7.8
11 Release:        2
12 License:        BSD (see LICENCE)
13 Group:          Libraries
14 Source0:        ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
15 # Source0-md5:  141132d6af14dccc7b08fa797e4fd441
16 Patch0:         %{name}-pcreposix-glibc-conflict.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.pcre.org/
19 BuildRequires:  autoconf >= 2.57
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel     
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  readline-devel  
25 BuildRequires:  zlib-devel      
26 Obsoletes:      libpcre0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 PCRE stands for the Perl Compatible Regular Expression library. It
31 contains routines to match text against regular expressions similar to
32 Perl's. It also contains a POSIX compatibility library.
33
34 %description -l es.UTF-8
35 A biblioteca PCRE é um set de funções que implementam expressões
36 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
37 sua própria API nativa, bem como um set de funções wrapper para
38 corresponder ao padrão POSIX de expressões regulares.
39
40 %description -l pl.UTF-8
41 PCRE (Perl-Compatible Regular Expression) oznacza bibliotekę wyrażeń
42 regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowujące
43 tekst do wyrażeń regularnych podobnych do tych znanych z Perla.
44 Zawiera także bibliotekę kompatybilną z POSIX.
45
46 %description -l pt_BR.UTF-8
47 A biblioteca PCRE é um conjunto de funções que implementam expressões
48 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
49 sua própria API nativa, bem como um conjuntos de funções wrapper para
50 corresponder ao padrão POSIX de expressões regulares.
51
52 %package devel
53 Summary:        Perl-Compatible Regular Expression header files and development documentation
54 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek pcre
55 Summary(pt_BR.UTF-8):   Arquivos para desenvolvimento com pcre
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Obsoletes:      libpcre0-devel
59
60 %description devel
61 Perl-Compatible Regular Expression header files and development
62 documentation.
63
64 %description devel -l es.UTF-8
65 A biblioteca PCRE é um set de funções que implementam expressões
66 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
67 sua própria API nativa, bem como um set de funções wrapper para
68 corresponder ao padrão POSIX de expressões regulares.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe i dokumentacja do bibliotek pcre.
72
73 %description devel -l pt_BR.UTF-8
74 A biblioteca PCRE é um conjunto de funções que implementam expressões
75 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
76 sua própria API nativa, bem como um conjunto de funções wrapper para
77 corresponder ao padrão POSIX de expressões regulares.
78
79 %package static
80 Summary:        Perl-Compatible Regular Expression static libraries
81 Summary(pl.UTF-8):      Biblioteki statyczne pcre
82 Summary(pt_BR.UTF-8):   Arquivos para desenvolvimento estático com pcre
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Perl-Compatible Regular Expression library static libraries.
88
89 %description static -l es.UTF-8
90 A biblioteca PCRE é um set de funções que implementam expressões
91 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
92 sua própria API nativa, bem como um set de funções wrapper para
93 corresponder ao padrão POSIX de expressões regulares.
94
95 %description static -l pl.UTF-8
96 Biblioteki statyczne pcre.
97
98 %description static -l pt_BR.UTF-8
99 A biblioteca PCRE é um conjunto de funções que implementam expressões
100 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
101 sua própria API nativa, bem como um conjunto de funções wrapper para
102 corresponder ao padrão POSIX de expressões regulares.
103
104 %package cxx
105 Summary:        C++ wrapper to PCRE library
106 Summary(pl.UTF-8):      Interfejs C++ do biblioteki PCRE
107 Group:          Libraries
108 Requires:       %{name} = %{version}-%{release}
109
110 %description cxx
111 C++ wrapper to PCRE library.
112
113 %description cxx -l pl.UTF-8
114 Interfejs C++ do biblioteki PCRE.
115
116 %package cxx-devel
117 Summary:        Header file for C++ wrapper to PCRE library
118 Summary(pl.UTF-8):      Plik nagłówkowy interfejsu C++ do biblioteki PCRE
119 Group:          Development/Libraries
120 Requires:       %{name}-cxx = %{version}-%{release}
121 Requires:       %{name}-devel = %{version}-%{release}
122 Requires:       libstdc++-devel
123
124 %description cxx-devel
125 Header file for C++ wrapper to PCRE library.
126
127 %description cxx-devel -l pl.UTF-8
128 Plik nagłówkowy interfejsu C++ do biblioteki PCRE.
129
130 %package cxx-static
131 Summary:        Static version of pcrecpp library
132 Summary(pl.UTF-8):      Statyczna wersja biblioteki pcrecpp
133 Group:          Development/Libraries
134 Requires:       %{name}-cxx-devel = %{version}-%{release}
135
136 %description cxx-static
137 Static version of pcrecpp library.
138
139 %description cxx-static -l pl.UTF-8
140 Statyczna wersja biblioteki pcrecpp.
141
142 %package -n pcregrep
143 Summary:        Grep using Perl Compatible Regular Expressions
144 Summary(pl.UTF-8):      Grep używający perlowych wyrażeń regularnych
145 Group:          Applications/Text
146 Obsoletes:      pgrep
147
148 %description -n pcregrep
149 pgrep is a grep workalike which uses perl-style regular expressions
150 instead of POSIX regular expressions.
151
152 %description -n pcregrep -l pl.UTF-8
153 pgrep jest programem działającym podobnie do grepa, ale używających
154 perlowych wyrażeń regularnych, a nie posiksowych.
155
156 %package -n pcretest
157 Summary:        A program for testing Perl-comaptible regular expressions
158 Summary(pl.UTF-8):      Program do testowania kompatybilnych z perlem wyrażeń regualarnych
159 Group:          Applications/Text
160
161 %description -n pcretest
162 pcretest is a program which you can use to test regular expression
163
164 %description -n pcretest -l pl.UTF-8
165 pcretest jest programem za pomocą można sprawdzić poprawność wyrażenia regularnego
166
167 %package doc-html
168 Summary:        Documentation for PCRE in HTML format
169 Summary(pl.UTF-8):      Dokumentacja dla PCRE w formacie HTML
170 Group:          Applications/Text
171
172 %description doc-html
173 Documentation for PCRE in HTML format.
174
175 %description doc-html -l pl.UTF-8
176 Dokumentacja dla PCRE w formacie HTML.
177
178 %prep
179 %setup -q
180 %patch0 -p1
181 %patch1 -p1
182
183 %build
184 %{__libtoolize}
185 %{__aclocal}
186 %{__autoconf}
187 %{__autoheader}
188 %{__automake}
189 %configure \
190         CXXLDFLAGS="%{rpmldflags}" \
191         %{!?with_static_libs:--enable-static=no} \
192         --enable-utf8 \
193         --enable-unicode-properties \
194         --enable-pcregrep-libz \
195         --enable-pcregrep-libbz2 \
196         --enable-pcretest-libreadline
197
198 %{__make}
199
200 %if %{with tests}
201 %{__make} check
202 %endif
203
204 %install
205 rm -rf $RPM_BUILD_ROOT
206 install -d $RPM_BUILD_ROOT{/%{_lib},%{_examplesdir}/%{name}-%{version}}
207
208 %{__make} install \
209         DESTDIR=$RPM_BUILD_ROOT
210
211 mv -f $RPM_BUILD_ROOT%{_libdir}/libpcre.so.* $RPM_BUILD_ROOT/%{_lib}
212 mv -f $RPM_BUILD_ROOT%{_libdir}/libpcreposix.so.* $RPM_BUILD_ROOT/%{_lib}
213
214 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libpcre.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpcre.so
215 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libpcreposix.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpcreposix.so
216
217 install pcredemo.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
218
219 rm -rf $RPM_BUILD_ROOT%{_docdir}/pcre
220
221 %clean
222 rm -rf $RPM_BUILD_ROOT
223
224 %post   -p /sbin/ldconfig
225 %postun -p /sbin/ldconfig
226
227 %post   cxx -p /sbin/ldconfig
228 %postun cxx -p /sbin/ldconfig
229
230 %files
231 %defattr(644,root,root,755)
232 %doc README NEWS LICENCE ChangeLog
233 %attr(755,root,root) /%{_lib}/libpcre.so.*.*.*
234 %attr(755,root,root) %ghost /%{_lib}/libpcre.so.0
235 %attr(755,root,root) /%{_lib}/libpcreposix.so.*.*.*
236 %attr(755,root,root) %ghost /%{_lib}/libpcreposix.so.0
237
238 %files devel
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_bindir}/pcre-config
241 %attr(755,root,root) %{_libdir}/libpcre.so
242 %attr(755,root,root) %{_libdir}/libpcreposix.so
243 %{_libdir}/libpcre.la
244 %{_libdir}/libpcreposix.la
245 %{_includedir}/pcre.h
246 %{_includedir}/pcreposix.h
247 %{_pkgconfigdir}/libpcre.pc
248 %{_mandir}/man1/pcre-config.1*
249 %{_mandir}/man3/pcre*.3*
250 %exclude %{_mandir}/man3/pcrecpp.3*
251 %{_examplesdir}/%{name}-%{version}
252
253 %if %{with static_libs}
254 %files static
255 %defattr(644,root,root,755)
256 %{_libdir}/libpcre.a
257 %{_libdir}/libpcreposix.a
258 %endif
259
260 %files cxx
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_libdir}/libpcrecpp.so.*.*.*
263 %attr(755,root,root) %ghost %{_libdir}/libpcrecpp.so.0
264
265 %files cxx-devel
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/libpcrecpp.so
268 %{_libdir}/libpcrecpp.la
269 %{_includedir}/pcrecpp.h
270 %{_includedir}/pcre_scanner.h
271 %{_includedir}/pcre_stringpiece.h
272 %{_includedir}/pcrecpparg.h
273 %{_pkgconfigdir}/libpcrecpp.pc
274 %{_mandir}/man3/pcrecpp.3*
275
276 %if %{with static_libs}
277 %files cxx-static
278 %defattr(644,root,root,755)
279 %{_libdir}/libpcrecpp.a
280 %endif
281
282 %files -n pcregrep
283 %defattr(644,root,root,755)
284 %attr(755,root,root) %{_bindir}/pcregrep
285 %{_mandir}/man1/pcregrep.1*
286
287 %files -n pcretest
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_bindir}/pcretest
290 %{_mandir}/man1/pcretest.1*
291
292 %files doc-html
293 %defattr(644,root,root,755)
294 %doc doc/html/*
This page took 0.047548 seconds and 4 git commands to generate.