]> git.pld-linux.org Git - packages/pcre.git/blob - pcre.spec
598dbcb1ffddc4594c1326592abfb122868261f2
[packages/pcre.git] / pcre.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  tests           # don't perform "make check"
5
6 Summary:        Perl-Compatible Regular Expression library
7 Summary(pl.UTF-8):      Biblioteka perlowych wyrażeń regularnych
8 Summary(pt_BR.UTF-8):   Biblioteca de expressões regulares versão
9 Name:           pcre
10 Version:        8.12
11 Release:        2
12 License:        BSD (see LICENCE)
13 Group:          Libraries
14 Source0:        ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
15 # Source0-md5:  7260dc8054e7d05f2286c26204da8f62
16 Patch0:         %{name}-pcreposix-glibc-conflict.patch
17 URL:            http://www.pcre.org/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake
20 BuildRequires:  bzip2-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  readline-devel
24 BuildRequires:  zlib-devel
25 Obsoletes:      libpcre0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 PCRE stands for the Perl Compatible Regular Expression library. It
30 contains routines to match text against regular expressions similar to
31 Perl's. It also contains a POSIX compatibility library.
32
33 %description -l es.UTF-8
34 A biblioteca PCRE é um set de funções que implementam expressões
35 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
36 sua própria API nativa, bem como um set de funções wrapper para
37 corresponder ao padrão POSIX de expressões regulares.
38
39 %description -l pl.UTF-8
40 PCRE (Perl-Compatible Regular Expression) oznacza bibliotekę wyrażeń
41 regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowujące
42 tekst do wyrażeń regularnych podobnych do tych znanych z Perla.
43 Zawiera także bibliotekę kompatybilną z POSIX.
44
45 %description -l pt_BR.UTF-8
46 A biblioteca PCRE é um conjunto de funções que implementam expressões
47 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
48 sua própria API nativa, bem como um conjuntos de funções wrapper para
49 corresponder ao padrão POSIX de expressões regulares.
50
51 %package devel
52 Summary:        Perl-Compatible Regular Expression header files and development documentation
53 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek pcre
54 Summary(pt_BR.UTF-8):   Arquivos para desenvolvimento com pcre
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Obsoletes:      libpcre0-devel
58
59 %description devel
60 Perl-Compatible Regular Expression header files and development
61 documentation.
62
63 %description devel -l es.UTF-8
64 A biblioteca PCRE é um set de funções que implementam expressões
65 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
66 sua própria API nativa, bem como um set de funções wrapper para
67 corresponder ao padrão POSIX de expressões regulares.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe i dokumentacja do bibliotek pcre.
71
72 %description devel -l pt_BR.UTF-8
73 A biblioteca PCRE é um conjunto de funções que implementam expressões
74 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
75 sua própria API nativa, bem como um conjunto de funções wrapper para
76 corresponder ao padrão POSIX de expressões regulares.
77
78 %package static
79 Summary:        Perl-Compatible Regular Expression static libraries
80 Summary(pl.UTF-8):      Biblioteki statyczne pcre
81 Summary(pt_BR.UTF-8):   Arquivos para desenvolvimento estático com pcre
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Perl-Compatible Regular Expression library static libraries.
87
88 %description static -l es.UTF-8
89 A biblioteca PCRE é um set de funções que implementam expressões
90 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
91 sua própria API nativa, bem como um set de funções wrapper para
92 corresponder ao padrão POSIX de expressões regulares.
93
94 %description static -l pl.UTF-8
95 Biblioteki statyczne pcre.
96
97 %description static -l pt_BR.UTF-8
98 A biblioteca PCRE é um conjunto de funções que implementam expressões
99 regulares utilizando-se da mesma sintaxe e semântica do perl 5. Possui
100 sua própria API nativa, bem como um conjunto de funções wrapper para
101 corresponder ao padrão POSIX de expressões regulares.
102
103 %package cxx
104 Summary:        C++ wrapper to PCRE library
105 Summary(pl.UTF-8):      Interfejs C++ do biblioteki PCRE
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108
109 %description cxx
110 C++ wrapper to PCRE library.
111
112 %description cxx -l pl.UTF-8
113 Interfejs C++ do biblioteki PCRE.
114
115 %package cxx-devel
116 Summary:        Header file for C++ wrapper to PCRE library
117 Summary(pl.UTF-8):      Plik nagłówkowy interfejsu C++ do biblioteki PCRE
118 Group:          Development/Libraries
119 Requires:       %{name}-cxx = %{version}-%{release}
120 Requires:       %{name}-devel = %{version}-%{release}
121 Requires:       libstdc++-devel
122
123 %description cxx-devel
124 Header file for C++ wrapper to PCRE library.
125
126 %description cxx-devel -l pl.UTF-8
127 Plik nagłówkowy interfejsu C++ do biblioteki PCRE.
128
129 %package cxx-static
130 Summary:        Static version of pcrecpp library
131 Summary(pl.UTF-8):      Statyczna wersja biblioteki pcrecpp
132 Group:          Development/Libraries
133 Requires:       %{name}-cxx-devel = %{version}-%{release}
134
135 %description cxx-static
136 Static version of pcrecpp library.
137
138 %description cxx-static -l pl.UTF-8
139 Statyczna wersja biblioteki pcrecpp.
140
141 %package -n pcregrep
142 Summary:        Grep using Perl Compatible Regular Expressions
143 Summary(pl.UTF-8):      Grep używający perlowych wyrażeń regularnych
144 Group:          Applications/Text
145 Obsoletes:      pgrep
146
147 %description -n pcregrep
148 pgrep is a grep workalike which uses perl-style regular expressions
149 instead of POSIX regular expressions.
150
151 %description -n pcregrep -l pl.UTF-8
152 pgrep jest programem działającym podobnie do grepa, ale używających
153 perlowych wyrażeń regularnych, a nie posiksowych.
154
155 %package -n pcretest
156 Summary:        A program for testing Perl-comaptible regular expressions
157 Summary(pl.UTF-8):      Program do testowania kompatybilnych z perlem wyrażeń regularnych
158 Group:          Applications/Text
159
160 %description -n pcretest
161 pcretest is a program which you can use to test regular expression.
162
163 %description -n pcretest -l pl.UTF-8
164 pcretest jest programem, za pomocą którego można sprawdzić poprawność
165 wyrażenia regularnego.
166
167 %package doc-html
168 Summary:        Documentation for PCRE in HTML format
169 Summary(pl.UTF-8):      Dokumentacja dla PCRE w formacie HTML
170 Group:          Applications/Text
171
172 %description doc-html
173 Documentation for PCRE in HTML format.
174
175 %description doc-html -l pl.UTF-8
176 Dokumentacja dla PCRE w formacie HTML.
177
178 %prep
179 %setup -q
180 %patch0 -p1
181
182 %build
183 %{__libtoolize}
184 %{__aclocal}
185 %{__autoconf}
186 %{__autoheader}
187 %{__automake}
188 %configure \
189         CXXLDFLAGS="%{rpmldflags}" \
190         %{!?with_static_libs:--disable-static} \
191         --enable-utf8 \
192         --enable-unicode-properties \
193         --enable-pcregrep-libz \
194         --enable-pcregrep-libbz2 \
195         --enable-pcretest-libreadline
196
197 %{__make}
198
199 %if %{with tests}
200 # tests need big stack
201 ulimit -s 32768
202 %{__make} check
203 %endif
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207 install -d $RPM_BUILD_ROOT{/%{_lib},%{_examplesdir}/%{name}-%{version}}
208
209 %{__make} install \
210         DESTDIR=$RPM_BUILD_ROOT
211
212 mv -f $RPM_BUILD_ROOT%{_libdir}/libpcre.so.* $RPM_BUILD_ROOT/%{_lib}
213 mv -f $RPM_BUILD_ROOT%{_libdir}/libpcreposix.so.* $RPM_BUILD_ROOT/%{_lib}
214
215 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libpcre.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpcre.so
216 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libpcreposix.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpcreposix.so
217
218 cp -a pcredemo.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
219
220 rm -rf $RPM_BUILD_ROOT%{_docdir}/pcre
221
222 %clean
223 rm -rf $RPM_BUILD_ROOT
224
225 %post   -p /sbin/ldconfig
226 %postun -p /sbin/ldconfig
227
228 %post   cxx -p /sbin/ldconfig
229 %postun cxx -p /sbin/ldconfig
230
231 %files
232 %defattr(644,root,root,755)
233 %doc README NEWS LICENCE ChangeLog
234 %attr(755,root,root) /%{_lib}/libpcre.so.*.*.*
235 %attr(755,root,root) %ghost /%{_lib}/libpcre.so.0
236 %attr(755,root,root) /%{_lib}/libpcreposix.so.*.*.*
237 %attr(755,root,root) %ghost /%{_lib}/libpcreposix.so.0
238
239 %files devel
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_bindir}/pcre-config
242 %attr(755,root,root) %{_libdir}/libpcre.so
243 %attr(755,root,root) %{_libdir}/libpcreposix.so
244 %{_libdir}/libpcre.la
245 %{_libdir}/libpcreposix.la
246 %{_includedir}/pcre.h
247 %{_includedir}/pcreposix.h
248 %{_pkgconfigdir}/libpcre.pc
249 %{_pkgconfigdir}/libpcreposix.pc
250 %{_mandir}/man1/pcre-config.1*
251 %{_mandir}/man3/pcre*.3*
252 %exclude %{_mandir}/man3/pcrecpp.3*
253 %{_examplesdir}/%{name}-%{version}
254
255 %if %{with static_libs}
256 %files static
257 %defattr(644,root,root,755)
258 %{_libdir}/libpcre.a
259 %{_libdir}/libpcreposix.a
260 %endif
261
262 %files cxx
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_libdir}/libpcrecpp.so.*.*.*
265 %attr(755,root,root) %ghost %{_libdir}/libpcrecpp.so.0
266
267 %files cxx-devel
268 %defattr(644,root,root,755)
269 %attr(755,root,root) %{_libdir}/libpcrecpp.so
270 %{_libdir}/libpcrecpp.la
271 %{_includedir}/pcrecpp.h
272 %{_includedir}/pcre_scanner.h
273 %{_includedir}/pcre_stringpiece.h
274 %{_includedir}/pcrecpparg.h
275 %{_pkgconfigdir}/libpcrecpp.pc
276 %{_mandir}/man3/pcrecpp.3*
277
278 %if %{with static_libs}
279 %files cxx-static
280 %defattr(644,root,root,755)
281 %{_libdir}/libpcrecpp.a
282 %endif
283
284 %files -n pcregrep
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_bindir}/pcregrep
287 %{_mandir}/man1/pcregrep.1*
288
289 %files -n pcretest
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_bindir}/pcretest
292 %{_mandir}/man1/pcretest.1*
293
294 %files doc-html
295 %defattr(644,root,root,755)
296 %doc doc/html/*
This page took 0.168617 seconds and 2 git commands to generate.